Access Point Name settings are not available for this user

Hi guys,

I have searched the forum before creating this, and I saw there were people with similar issues, but I still couldn’t fix the problem with my mobile data. I am hoping someone can help.

I have Fairphone 5, OS is Android 13.

I am in UK and use Lycamobile as my mobile provider. Lycamobile is my second SIM and I use it as eSIM.

The following happened after I downloaded the eSIM - I set up everything as instructed by my provider and everything was working fine for a couple of weeks. After that, mobile internet stopped working with Lyca (the internet on physical SIM has worked and still works fine).

I called Lyca’s customer support multiple times, but they were not able to help - they were instructing me to change APN settings or reset them to default. Neither worked. You can access the APN setting and type APN name, password etc. but the changes are never saved. The initial screen with APN settings kept showing “Access Point Name settings are not available for this user”. It didn’t help to change the “reset to default” (reset the APN) or resetting phone (including factory reset).

I came to the conclusion my eSIM must be corrupt or something, so I decided to erase it, get a new one (stil with Lycamobile). I got new eSIM, transferred my old number and everything was working once again. -THIS ONLY LASTED about two weeks. Now I’m on square one again. Internet is not working for Lyca and APN setting seems to be deleted with no possibility to save new ones.

1 Like

Its not saved automatically you have to click on the three dots and on save…

Hi yvmuelli, thank you for your reply. I have done exactly what you’re saying. I click the three dots, then the option “save” appears, I tap save, but it changes anything. When I later go back I still have the message that the APN settings are not available (and what’ve have saved is not there either)

1 Like

Did you try to add a new one using the + sign and then probably even delete the old one?

1 Like

I do it via the plus symbol, but the old APN setting is not there (already before I add anything). In other words - there’s nothing to delete

So there is no APN at all? Sorry it seems you mentioned that already and I did not understand.

So what are the network settings: 5G enabled? VoLTE/4G Calling enabled? Wifi Calling enabled? Can you disable all this?

Can you disable or even take out the physical SIM and see what happens?

Yes, no APN details are visible. You can click on the three dots and change them, but they never get saved (after tapping “save”).

I’m trying to attach the screen for APN settings (hopefully it gets sent).

I tried disabling everything you said, but it doesn’t work. Then I disabled it and restarted the phone, but still no change

You cant change what does not exist the only that should work in your case is adding a new one using the +

This is how it should look when an APN exist

Thats def weird and I would say a provider issue…

When you tap + you can change stuff, but it doesn’t get saved. I did delete SIM previously and a got new one. Everything worked fine for about two weeks, untill the APN details disappeared again

I understood. What about

Still in my eyes a more than weird provider issue as it happened twice.

@michal_s did you find a solution for this in the end?

I have just bought a new Fairphone 5, installed a Lyca e-sim and came across the exact same issue as you.

Same message in the APN settings “Access Point Name Settings are not available for this user”

An same issue that when I click “save” after filling out the APN requirements, it doesn’t actually save.

Hoping someone has found a solution to this!

Carrier configs automatically loaded for a MCC/MNC can block editing APN config.
The best option is to switch to an OS which ignores such silly restrictions.

Well adding a new APN is probably the first step before changing OS and contact to the provider who blocks the config

Hi and welcome, please contact your provider and FP support if all the above does not help/work.

As I understand APN1 is fixed but that really doesn’t matter? If it stops adding an APN in addition that’s a problem.

This is not just your device, on iOS we have APN for O2 (which is renamed as Lycamobile but it’s really just O2s network identifier and a polish network Plus). As the sim includes these within a field “sim applications” we have no route to remove them and we cannot edit them, however iOS responds by effectively saying “no” and applies no APN, instead requesting the carrier issues it over SMS message (hidden to the user). It then uses this and only this. The user can force a manual override by going into a menu that is located within the sim/esim settings and choosing sim applications - manual - and forcing it. This generally just breaks things :slight_smile:

Due to the 3G switchover and significant modifications in how EE interface with profiles, automated APN configuration is problematic.

Users who were with Lyca when it was o2 will likely still have the o2 APN which dynamically adjusted during the initial migration; anyone joining afterwards needs to leverage the new APN. This changed after the EE 3G switch off.

I’m on iOS so I may not marry up identically in the settings, but I’m sure it’s workable:

For Internet:
Name: EE Internet
APN: everywhere
Username: lmuk
Password: plus
MCC: 234 (if required)

See below details of how to configure on android from the Lycamobile Chat Bot:

I am unclear why but access to 5G is non-functional right now at least on iOS. Theres 30+ posts from iOS users on the Lycamobile Facebook, I am unsure if this applies to android as everyone so far who’s confirmed 5G stopped working is on iOS. Overall, I really think Lyca is a hot mess right now.

See my message above for manual APN (if device allows adding an extra APN) else APN deployment can be remotely issued via the Lyca Bot.

This is how most iOS users are getting things to actually work.

Click the chat bot icon

Enter your info

Type APN

follow prompts to send automatically. I am unsure if this is supported on this specific make/model but hey, worth a shot!