802.1x do not validate option bugged

When I try to connect to an SSID that uses 802.1x.
The option do not validate just closes the settings, it does not want to attempt to connect.
When I leave it blank I do not get the option Trust on first use that other devices do.
Currently running android 13,
The option use system certificates or install certificates is not an option supported by the IT team as of the time I am writing this.

Does anyone have expierence with issues regarding fairphone and 802.1x?

Hi! Please take a look at this thread.