4G Refuses to Work

Hello guys,

I’ve read the other topics about this (Fairphone forums and others) and nothing that helped.
So, basically, here’s the rundown:

  • the Fairphone I currently possess is set to 4G preferred;
  • I have only one SIM card inside and it’s recently acquired just for the purpose of 4G (Telekom, Romania);
  • my subcription is 4G;
  • the location I am has 4G cover;
  • the APN’s for Telekom are correctly set.

Yet I have not seen the 4G signal once on this phone.
I get an H+ when I turn the mobile data on and most of the time it goes to E when I want to do some browsing and it’s really disappointing.

The only solution I can come up with at the moment to is to have a go at a Telekom representation and see what they can come up with. Maybe they could pinpoint the problem? Is it the phone’s fault? Or something else? I guess I have to find out and update the thread.

In the meantime, did you guys encountered this problem? Did you found any fixes? Any tips?
Did 4G connection never gave you any trouble at all?

Thank you.

P.S. The SIM is losing signal from time to time when I turn on the mobile data; never happened on my 8 years old SIM.

Is the SIM inserted in slot 1 or 2?

Slot 1.
Does the same thing on slot 2.

Is your SIM really 8 years old? Then it might not support 4G.

I’m not using the 8 years old SIM.
I took a 4G SIM recently so I can benefit the 4G from my subscription that I was paying for it anyway.

Since Telekom Rumania is a 100% daughter of Deutsche Telekom, your new SIM might be affected by a problem, that other Telekom clients (also T-Mobile Austria and Congstar) experienced. Have a look here:

The problem was solved by an FP2 update, but you might be affected.
Check the version number of you SIM.

1 Like

There are rare cases where people who have “exotic” phones (which their network operator does not know) have to connect to the network once with a “common” phone (Samsung / Apple / whatever). The network then recognizes that the subscriber has a 4G enabled phone and automatically activates 4G for the SIM card. After that, 4G also works in the “exotic” phone.

Could you try that?


This hasn’t crossed my mind. Great suggestion.
Sadly, I don’t know anyone in my social circle with a phone unlocked.
All of my friends has a Vodafone contract.
I just tried two phones from my family and Vodafone network forbids my Telekom SIM to activate the mobile data.
This might just solve my problem but since I don’t know anyone with an “independent” phone that has 4G capability, going to a Telekom representation is still a better solution.

Yeah, just asking them to try your SIM in one of their 4G phones would be best. If that doesn’t work, it’s their problem and they have to fix it. If it works, there is a good chance that it will also work in the FP2 afterwards.


Problem solved.
I went to a representation and they told me to call the support line in order for them to activate 4G on my phone. In the end, I had to do what I hated the most… to call them lol.

Anyway, 4G works now. Thread solved.

1 Like