English

Your device isn't compatible with this version (of skype, telegram)

Hi, i’ve just bought a refurbished FP2 from the Phone Coop to replace my last one which went down the pan (literally :-/)
I’ve downloaded most of the apps, but can’t download some apps - e.g. skype, telegram. The message is “your device isn’t compatible with this version” (of the operating system presumably). I also can’t even find some apps in the google playstore.
I’ve updated the OS to the most up to date version.
Any clues? (I’m trying to get tech support from the Phone Coop but they’re not answering, so any help would be gratefully received).
Many thanks
Lesley

Can you specify your OS version? The most recent version should be 19.11.2. The “Updater” app should show you this version number.

1 Like

Thanks urs_lesse
It’s 19.11.2.
The chap at the Phone Coop (who isn’t a FP specialist) suggested it’s because I’m abroad. My husband (tech specialist but not FP) says this is not likely - other apps can be downloaded.
Only a few fail (Telegram, Keep, Skype) because of the apparent incompatibility issue - and I can’t even see them listed in Google Play Store.
I’ve cleared all the data and cache in the Google Play Store and Play Services apps but no change.

1 Like

Very odd indeed. I just tested again, and I have no issue running Telegram even on my FP1 (Android 4.2.2).

1 Like

Yes, i never had issues before. Only this phone which is new to me (but a refurb)

What happens when you try to start the download from you browser:

Is it then that you get the error message?

If it still doesn’t work, I would try downloading the app with an alternative store, like aurora. For Telegram, you can also find the apk on their website:

The error message appears after I located Telegram in the Google play store (Telegram is visible in the play store, unlike the others).

I just installed and tried Aurora - thanks for this suggestion (good to know). Note I am using Aurora anonymously as suggested by the app.

But, even in Aurora, the Skype app didn’t appear when I searched for it, nor Telegram, nor Keep.

So what happens when you try with an app which is not visible from the Play Store, like Skype?

I’ve just installed FDroid from the website, and it installed correctly. So, does it seem like it’s a google play problem? (I deleted the cache and data from google play services earlier)

Well, you might want to check this list of countries restricting the access to Skype:
https://www.quora.com/In-which-countries-is-Skype-or-WhatsApp-calling-blocked

If you are in one of these countries right now, it might explain why Play store blocks Skype and such (I guess that Telegram is not very popular either in those countries).

I’ve just seen Skype in the playstore but it won’t install (not compatible). When I tried to install it from the website, the phone behaves errantly - e.g. the wifi cuts off.
Then, after apparently downloading, it tells me in playstore that skype is downloaded, but then it doesn’t appear in the list of apps.

The search function in aurora isn’t working - it doesn’t find signal, telegram, trello etc.
WiFi is on-off all the time.
Does this seem like the refurbishment process has got some errors?

Thanks Chrisse, it’s not that, I have skype installed on all my other devices. It’s also Trello, Telegram not just Skype. In any case you should still see the app in Playstore.

I have done a factory reset and the same problems have returned.

I’ve been informed that it’s because the refurb FP2 I purchased has an old OS instlaled - Android 7.
Hoping that FairPhone will talk me through how to replace the OS withe latest OS.

Android 7 is the latest official OS for FP2:


And the apps you mention are compatible with this version.

I doubt that this is your problem.

If you want a more recent version of Android, you can try Lineage. Not too difficult to install, but not official.
But once again, your problem is not related to Android’s version.

If you are abroad in one of the countries listed in my link, it may be so that you can use Skype if it already been installed on the device before you were in this country, but you cannot download it from this country.

1 Like

What I would do now if I were you, is:

  1. restart the phone
  2. log out of your Google account
  3. Log in again
  4. open Play store and check again.

If it doesn’t work you can try with another store. If Aurora doesn’t work , there are many other options. Try searching “apk download”. It would be a good way to know if you manage to install skype with the apk.

Hi Chrisse,
Thanks for the suggestions.
Telegram, skype and Trello aren’t visible in Aurora or F-Droid.
We then downloaded the telegram apk from telegram website and managed to install it onto the phone and it’s working. :slight_smile: But this doesn’t seem possible for skype and trello.
I’m still not sure that it’s because I’m abroad - I have other android phones on which I’m able both to see the app in the playstore and download them. And I have also tried both with and without ExpressVPN set to the UK.

I have been advised by phone coop to install lineage.
Does anyone know where I can get it from, and instructions to install?

Sorry if this creates more confusion, but perhaps you could try two other things first. My first approach would be to re-install Fairphone OS 19.11.2 manually. If that doesn’t make a difference to your problems: Do a factory reset.

If both of these options don’t help, you can still try LineageOS. I’m not recommending against LOS at all (if I were using the FP2 as my everyday phone, I would use it), but I’m not so sure it will make a difference with your problems if they cannot be fixed under a standard Fairphone OS.

Just some experiences from my side. I’m using Lineage OS for years now on several devices. The problem with incompatible apps sometimes also appears on Lineage OS.

Usually if I find an application not in Aurora I download it from apkmirror.com I think this website is trustable. They provide only APKs with original playstore signature. There even you can choose the version you want if you ever have problems with a specific version. Apkmirror.com does not work for paid applications.

Another option is to use the Application sharing feature from F-Droid. You can use that to transfer an application from one device to another. Both devices need a recent version of F-Droid. But to be honest that feature is very buggy and F-Droid crashes often using that feature. But it can help in cases where nothing else helpes.

2 Likes