English

XPosed Framework can´t find the right version

Hello,
I would like to install XPrivacy on my FP2 with Open OS 18.04.1. I followed this guide on first steps on the OpenOS.

When I selected the SDK Level 22 for Android 5 in the XPosed Downloader, as indicated, there was an error in the installation of the zip file during TWRP – not the right version for my phone. So I selected SDK 23 for Android 6, the installation works but I get an error in the XPosed Installer – “Xposed is (not) yet compatible with Android-SDK-Version 23 or your Prozessor-Architektur (armeabi-v7a).”, and XPrivacy doesn´t work (“Privacy Service not found.”). I tried version v87-sdk23-arm.zip and v89.

I also read this.

Thanks in advance for any help!

1 Like

Xprivacy in itself is not maintained anymore, but there’s a successor, xprivacylua. Just check the package on f-droid and follow the documentation. It did work on Android 6, and it also should work on 7. I left it because when i switched to 7 there was no xposed, and i left it at this. I’m using island now for privacy violating apps

Thanks for the answer, but my problems are starting earlier: the framework doesn´t work, so neither XPrivacy nor xprivacylua will work until this is fixed (I tried both but they tell me there is no framework).

Yeah, i was more thinking of getting install information including how to get and install the requisite xposed framework before xprivacy. As most of the time the developer’s docs were very good

Thanks! I managed by downloading the xposed installer from this xda developers link and then the framework was fine. The F-Droid installer version didn´t work for some reason. I had to download xprivacylua from the module repository once more aswell and now all is fine.

2 Likes

Still, one more question, maybe I don´t get it… I have tested some app restrictions, in some cases they seem to work (e.g. OpenCamera could not be used when it was restricted camera access), but all my messenger apps (Threema, Telegram, Signal, WhatsApp) - what I installed it for in the first place - aren´t affected at all, even if I restrict everything: I can message, take and send pictures, everything as always. Any ideas on what´s the problem here…?

It actually tells me in the XPrivacy menu the exact date and time when the app did the thing I want to restrict (e.g. use camera), text in grey at the left side.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.