English

🇩🇪 WLAN Verbindung bricht ab und lässt sich nicht mehr verbinden

Tags: #<Tag:0x00007f05d9b03e80> #<Tag:0x00007f05d9b03cf0>

Hallo.

Mein Fairphone verliert in regelmäßigen Abständen die WLAN Verbindung. Bisher musste ich WLAN nur einemal aus und wieder einschalten, dann ging es wieder. Seit dem Update auf Android 7 reicht das aber nicht mehr. Selbst wenn ich das Netz anwähle und auf Verbinden klicke, passiert einfach nichts. Ich muss das Handy einmal Neustarten, dann verbindet sich das FP mit dem Netz (sowohl zu Hause als auch auf der Arbeit), aber nach ca. ner halben Stunde oder Stunde ist die Verbindung getrennt und ich muss das Handy neu starten.
Gibt es hier abhilfe?

VG,

Sascha

1 Like

Probier’ mal kurz den Flugmodus ein- und wieder auszuschalten.

1 Like

Ich habe diesen Fehler auch, meine “Lösung” war einfach nur noch mobile Daten zu verwenden… nicht im Sinne des Erfinders. Ich hatte erst meine FRITZ!Box im Verdacht, aber das Problem habe ich auch mit anderen WLAN APs.

Edit: Warum nur noch mobile Daten… das Problem ist die App Orbot, die durch die ständigen Re-Connects und dem Wechsel zwischen WLAN und Daten nicht sauber läuft und ich damit dann nicht mehr sauber via Tor ins Internet komme.

Mein OS ist allerdings nicht Android 7, sondern LineageOS 15 - also Android 8.1.

Bei mir hat der Workaround mit Flugmodus ein / aus geholfen.
Vielen Dank an Urs!

2 Likes

Die problematischen WLANs werden nicht zufällig von Apple-Routern bereitgestellt? Da gab’s mit LineageOS mal Probleme, allerdings gleich mit Reboot.

Nein, u.a. waren es auch TPLink-Geräte mit Freifunk-Firmware…

Ich habe seit ein paar Wochen ein sehr ähnliches Problem. Die WLAN-Verbindung bricht nach kurzer Zeit ab, wenn ein anderes (unbekanntes) Netzwerk mit ähnlicher oder höherer Signalstärke vorhanden ist. Mein FP2 (Android 7, Google) trennt dann immer wieder die aktuelle Verbindung und versucht sie neu aufzubauen. Irgendwann ist auch damit Schluss und die WLAN-Verbindung bleibt unterbrochen.
Der Workaround Flugmodus on/off hilft temporär. Am besten lässt man das Gerät in unmittelbarer Nähe zum Router liegen.
Das Problem tauchte übrigends nicht unmittelbar nach dem Update auf Android 7 auf, sondern erst einige Wochen später.

Vielen Dank und beste GrĂĽĂźe
Werner

2 Likes

Update: Der Workaround aus einem anderen Thread, im heimischen WLAN das 5 GHz-Netz auszuschalten und nur noch das 2,4 GHz-Band zu nutzen, scheint auch bei mir zu funktionieren. Ich muss das allerdings noch ein paar Tage so weiterlaufen lassen, um das endgültig zu bestätigen.
… Nach einer Woche mit nur einem WiFi-Band bleiben die Verbindungen weiterhin stabil. Scheint also ein funktionierender Botch zu sein.