English

WLAN can't be turned on anymore after update to Android 9

Hello,
I have just done an update from Android 7 to Android 9 with Fairphone Open and now my FP2 can’t find any WLAN-networks anymore.
Any suggestions on how to troubleshoot?

Michael

What you could try is to remove the wifi network.
Go to the app Settings,
Network and internet
remove the Network
and then add your network again.
Sometimes a reset of the settings helps.

1 Like

The problem is different. The phone can’t find any WiFi networks at all. There is nothing to remove.

1 Like

Reboot your phone.
Switch the wifi off and on.
If the wifi doesn’t find anything, then add a wifi-network manually.

1 Like

Done all of that.
No success.
Can’t add my network manually either.

1 Like

Perhaps you have to re-apply the update.

1 Like

Did re-apply the update. No change.
I can’t activate WLAN. When I do, it “jumps” right back to de-activated.

1 Like

I would report to bug tracker

1 Like

Settings - System - Advanced - Reset options - Reset Wi-Fi, mobile & Bluetooth - Reset Settings

Any change?

Did that, too. No change.

1 Like

Just did the update to 21.08
Still no WLAN possible.
I’m wondering if this is related to the fact that on Android 7, I had Xposed with Gravity Box and XPrivacyLua installed.
After updating to Android 9 through TWRP, uninstalled Xposed, Gravity Box and XPrivacyLua.

That certainly could be the cause…

And what should I do now?

Reinstall from scratch I guess.