With headset, ringtone doesn't work

When I have the headset attached (from an older Samsung phone, with mic), the ringtone doesn’t work. The outer speaker is muted (which is to be expected since the headphones are on), but the ringtone doesn’t sound over the headset either. When I actually see someone calling (the screen lights up) and I answer the call, it works fine.

Is there a setting I should set? I can’t find anything about this in the profiles settings.

I am using the FP OS, I also have Llama for profiles but have not configured any profiles based on the headset and I am also not using Llama ringtones (yet).

Any ideas?

Would installing xposed with gravitybox work?


1 Like

My phone definitly rings with the headphones attached (over the headphone). Check the volume settings, perhaps there are different settings saved for with and without headphones attached and the ringtone is simply muted.

There should be no need to install GravityBox for this.

No, I couldn’t find settings for with/without headset. I did find out something, though.

Seems when my volume is on 1/7 (which it usually is), it doesn’t ring when the headset is attached.
But when I set the ringtone volume to 2/7, it does work! And not only over the headset, but also on the outer speaker.

Weird that the volume seems one step down (0/7 when on 1/7, 1/7 when on 2/7).
And weird that the outer speaker is also used when the headset is attached. (I tried it with a headset with mic and a headset without a mic - both same results.) When I have the headset attached, I do that also because I don’t want to let the outer speaker make any noise.

1 Like

Really interesting, i will try to reproduce this. I cannot remember
having any sound on the external speaker when a headphone/set is connected.

Sure, very annoying.

Same for me, when I have the headset connected ringtones play even through the external speaker so I assume it’s normal behavior (and thinking about user experience I suppose this is due to the need to alert the user of an incoming call, if (s)he leaves the phone on a table with the headset connected)
About sound levels, I noticed the volume quite off at the first level only on sound notifications not on ringtones, but I use SoundManager app to switch profiles so maybe this is due to its handling of different sound channels (I have separate profiles for ringtones and for notifications).
Bye! :smile:

1 Like

The same here. Must have been my old Nokia that played only through the Headphone when connected.

1 Like

To me it sounds like some kind of incompatibility with sound profile apps:

So it would not be a Fairphone bug, but rather an incompatibility or bugs in the apps. This might be influenced by the operating system, or android version?

I don’t remember if this “issue” happened before installing SoundManager, but it behaves the same even disabling the profiles handling so I suppose this is a “feature” of Android (at least Jellybean :wink: this is my first Android phone so I can’t say anything about different versions)

Have you tried deactivating, or uninstalling SoundManager, and reproducing the error? I guess that the app has permissions to set the profiles, thus creating the error.

So it was disabled when I did one of my tests.
Moreover I don’t consider it an error, because I find it useful to have the ringtone sound even when I leave my phone on the desk, with the headset connected.
I would prefer to have an option to enable or disable this “feature” but it’s ok for me :slight_smile:


I see, I wasn’t sure if you meant that you disabled the app, or some setting within the app.

I am happy to hear that :smiley: