WIFI-symbol grey after latest update (1.8.7) - workaround not working


I have the same problem as after update to 1.8.5 (Problem with WhatsApp and others after Update to 1.8.5) - but now the download of an app from the store works only till restart of the phone - then WIFI is grey again.


Try this:

and post back if it helped

Is it really the WiFi not working thing or just that the symbol stays grey, i.e. no connection to google services = no push notifications?

I have the latter problem and was able to fix it using the help from this post: Help with Xprivacy settings relating to Google Apps

The part where you use a terminal emulator on the phone or adb from a PC and type

am startservice -n com.google.android.gsf/.gtalkservice.service.GTalkService

@Brackmeister: You are right - WIFI is working fine - only google services (push notifications) not working.

I’ll try your solution and report


Same thing as installing a new app: WIFI getting blue - but after restart of the phone it turns grey again

1 Like

I have the same problem, but I am pretty sure i already had it before 1.8.7, i just don’t reboot or turn off my phone very often. However, typically when I do, the Wifi-Symbol stays grey until I update an arbitrary app.

Sadly, some push notifications seem not to work reliable until i do so (WhatsApp/Telegram).

1 Like

I had the same problem - i think since 1.8 - i use the app “Root- Push Notifications Fixer” (https://play.google.com/store/apps/details?id=com.andqlimax.pushfixer&hl=de) It fixes the Heartbeat interval times of the GCM /Google Push Network. Now it works fine!
An other app I use is the “Push Notification Tester” (https://play.google.com/store/apps/details?id=com.firstrowria.pushnotificationtester&hl=de) Does exactly what the title says. It tests if you can receive push notifications = if your connection with the GCM Network is running properly.


I installed the two apps - What did you change with the Root-Push Notification Fixer (values for intervall)


I have had the same problem as you after the last two updates (not this time though). Fortunately, the problem ceased to exist after a couple of days each time. In the first days after an update I would have to download some app everytime I restarted the phone. After a week or so, the problem was miraculously solved. Before that, I once called support, but they couldn’t help me either, although they were aware of the problem - at least one FP employee was affected too. Maybe you wait for a week or so and see whether the problem persists…

I guess you tested with “Push Notification Tester”? And no push notification arrived at your phone?

If yes >> then go in the “Root- Push Notifications Fixer” app. Look at the SETTINGS and check if Mobile heartbeat interval is set to 6 and Wi-Fi Heartbeat interval to 5 (like it is recommended) and then click on “apply settings” and restart your phone. that’s it. I hope it also works in your case!

After the upgrade to 1.8.7 seems that the wifi is not working. Wifi icon is gray.

A grey wifi icon does only indicate that something is not working in relation to Google Services. It is not an indicator for a broken wifi.

I had to reboot twice in the meantime. After the first reboot, the symbol stayed grey for maybe 15 minutes, after the second for about an hour.

It seems sort of ok-ish as I typically don’t reboot too often.