WiFi problems with FP3

I bought 2 FP3 (one for me and one for my wife) a couple of month ago and since yet everything worked well.
Last week, I changed my router box and now I have big WLAN problems with my 2 FP3. I first thought it was the new router and I had it changed but it’s not better with the new one.
My FP3s are always on the 4G and if I connect on the WLAN it’s very slow. Impossible to have a Whatsapp video or even audio call.
After several tests, it seems that it is specifically a problem with the FP3 because 3 other devices (TV box, notebook and Samsung Tab) work well with the WLAN.
When I test the stability of the connexion with my router (ping test on, it’s awfully slow. The time ping is around 450ms (whereas it’s about 8ms with my notebook on WLAN (same place)) and several pings don’t even reach the router.
I read different topics on the subject and I tried many things :
desactivate the 2,4Ghz or the 5Ghz
choose some specific canal (on 2,4 or 5Ghz)
But nothing seems to work.
I also test the security protocol issue : I tried to create a guest WLAN without security and it doesn’t work better…
Does anyone have an idea ?
Thank you

1 Like

What is the name and modelnumber of your router?


Hello Lidwien,
It’s a box delivered by my provider (UPC) in Switzerland.
Here is the link to the manual :


There were numerous threads about Wi-Fi issues here already. For a start, you might want to check out

Good luck!

1 Like

Well yes, I already read all of these topics, but no way… it didn’t help me finding a solution…

1 Like

What is the setting for Wireless mode 802.11? see page 29 of the manual.


Actually I already tried the different possibility of these settings. Now, it’s 802.11n for the 2.4 and 802.11a/n/ac with the 5 Ghz.
By the way, a friend of mine have the same box but with a Ubiquiti Unifi AP in addition. I’m going to try to connect to his WLAN and see if the connection is better.
Results in a couple of minutes…

1 Like

So here are the results :
The connection to the WLAN of my friend (same box but with a Ubiquiti Unifi) is much more stable and fast. Test ping with the router is about 12ms…
So, I know now that it would be a solution : buy a Ubiquiti AP, but I found annoying not to find what is the problem between my box and my FP3…

1 Like

There’s different price ranges for Ubiquiti APs, and they last for years. There’s also a second hand market for these.

I wouldn’t trust these (LibertyGlobal) routers anyway. Often, they don’t get firmware updates and such. I’d check if there was one available for your router, and contact your ISP to inform them you have coverage issues.

You might also have success with a repeater. Some ISPs provide these for free, or with a discount (I know VodafoneZiggo ( = joint venture betweeen LibertyGlobal and Vodafone specific for NL) provide these relatively cheap, for “cost price”).

1 Like

Ok, the “solution” I found is that I connect my old router on the network and create a WLAN with it specifically for my FP3. So I now have 2 WLAN, one from my new box for my laptop, tab and TV box and one from the old one for my FP3s…
I wouln’t say it’s the most sexiest way to solve the problem, but it works…
So, thanks for your helps

Hello Pascal, my WLAN speed using 5 GHz with my FP3 ist also extremly slow. I have a 250 MB contract with Telekom Germany. Within the last weeks the best average speed meassured with my FP3 was between 40 and 120 MB maximum. I compared the Speed with my old Samsung Note Pro 12.2. This Tablet made it through 250 MB in the same Network, I have the Speedport Smart 3 Router from Telekom with the latest Firmware. In addition, there are two mesh repeater working, using the 5 GHz as well.
Regards Harald

Set your router to WPA/WPA2 and 802.11b+g (only) reboot and all should be good

1 Like

Hello ! Thank you for your replies.
Well, Suzanna, I really think you’re right. It surely is a problem with the security protocol and/or with the Wifi signal. BUT… my router do not propose 802.11b+g (only). The only three possibilities are : 1) 802.11n ; 2) 802.11g+n mixed ; 3) 802.11b+g+n mixed. So I can’t inactivate the 802.11n protocol… That’s the problem I think…

I wanted to point anyone reading this thread to also check out information here

The following setting changes fixed the issue in my case (works on Cisco APs, but I guess it’s the same for others if configuration is possible):

If using PSK:
Set FT to “Enabled”
Enable PSK and FT+PSK under WLAN configuration
If using dot1x:
Set FT to “Enabled”
Enable dot1x and FT+dot1x under WLAN configuration

This compatibility issue was triggered by the introduction of support for Adaptive FT for Android in 8.10/16.12.1. (The “DEO_IE”.) Some Android 10 clients have a bug wherein, if they encounter a “DEO_IE”, they fail to attempt to associate.

See full article here (login required):


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.