English

Wifi drains battery after Marshmallow Upgrade - See first post

Has battery life improved with Fairphone OS 17.05.2?

mY battery time has double in 6.0 ! O-o ,

Same issue with loudspeaker, after latest update the bug appears as solved.
I use FP2 for business, intensive WiFi and voice calls, battery never lasted more than one day

A post was split to a new topic: Repeated “Google Services Framework has stopped” error after Android 6 upgrade

Battery life has never been great with my FP2 but it definitely got worse with Android 6.
My battery lost 50% in less than 10 hours in which I have hardly used the phone. WiFi was of course switched off. Also background scanning is off.

Hi, I have the same Problem. Wifi is deactivated, all scannings are off.
But Wifi is continously shown as active in the battery usage overview… that seems a big bug in some cases.
Battery drain is therefore very high.
Has anyone any idea?

Yes. Read the #batteryguide :wink:
Edit: Just to be clear: As I already said, this problem is solved for me after resetting the battery.

1 Like

[quote=“filderalex, post:26, topic:27783”]
But Wifi is continously shown as active in the battery usage overview… that seems a big bug in some cases.
Battery drain is therefore very high. [/quote]
I also see a lot of wifi usage there while wifi had been off, but I am not actually experiencing any battery drain because of it. Battery life is quite comparable to what it was with Android 5. The incorrect reading for wifi usage could be an unrelated issue.

Hello Sevan,

Did you find these “three dots” on your phone, because I cannot. And no, Lidwien, it is not the same page as you get to when clicking “Mode”. However it might do the same thing, but reading the link posted by Sevan it does not seem to be the case. Since in that guide he both sets the Mode to “Device Only” AND sets WIFI-Scanning to “off”

M

1 Like

I have a Fairphone 2. And I am experiencing something estrange with the Maps app.

I have the location deactivated, and google location services and history location as well. The google maps app is closed. (but not stopped since it insist in restart automatically in the background without asking)
After 1 day I can see that Maps appears in the first place of battery use list. with a mark of 22% (without opening it, and with location deactivated)
It seems that the app is consuming battery just trying to check if it can locate you.

I think that this is a problem related to Android more than Fairphone, but I would like to ask if more people is observing this behaviour. Does anyone have a solution (other than uninstall google maps?)

Most many other users describe a high battery consumption from wifi (:gb: here and especially :de: hier).
It could both be related though.

What happens if you deactivate the App for a day or so?


PS:

Ok, that means it is the same issue, so @Pepelisu I moved your post and the following discussion here.

A few things to get Google Maps to behave are showing up when googling this, among them clearing Maps cache and data or disabling Maps sound promising.

I just don’t see a disable option for Maps with my Fairphone Open OS + Open GApps, but I could just uninstall Maps, perhaps that’s why, I don’t know.

I can also almost visually imagine Google Maps hammering your system in the background “givemelocationgivemelocationgivemelocation…”, which would explain the battery usage, but I don’t know if it works that way :slight_smile:

1 Like

I had already googled exactly the same search and I found exactly that.
I disabled Google Maps (the result is a complete uninstall, do not ask me why you can not simply disable it) and now the problem is the wifi. It seems that one of the apps is trying to use location and or data all the time. I will keep an eye on the Apps that I recently install since this was not happening al the beginning, with a clean installation of android 6.0.

The funny thing is that location is deactivated for all the apps and was only allowed in the google maps app. It seems that some Apps do not take in account that location is deactivated and keep trying to access to it therefore consuming more battery.

Could this be related to other users concerned about wifi being the main battery drain?

Maybe it helps to wipe the cache, as demonstrated in a video for the Nexus 6P and 5X:

Can’t find the three dots anymore.
However I can access the parameter via
Settings > Search (the magnifying glass icon on the upper right) and seaching for “scanning”

Odd, which version of FPOS do you have, 17.05.2?
This is my result when searching for ‘scanning’

Try the Swedish word for “scanning”.

Hi,

Would not help, my phone language is in English, only the keyboard is Swedish, not evident from my screenshot I see…
It seems that my phone is still indexing the setting chapters, when I started searching for scanning, even putting only ‘s’ would not give me anything, even though a lot of the settings start with ‘S’. But now after messing around a bit I get the results “screen lock” “SIM card lock” etc. Seems the list is increasing. Which is weird, since I’ve had Marshmallow since FP released it a couple of weeks back. Maybe if I wait a while

But I found the setting under WIFI instead:
When disconnected from WIFI i had a small text in the middle of the screen beneath the text “To see available networks, turn WI-FI on” looking something like this:
“Your WIFI is disconnected. However some apps may still use it to improve location, go to Scanning to change this setting.”

Now I cannot find the setting anymore since I ticked it off… But I don’t need it anymore, so I guess the problem is solved for me =). Would be nice to be able to access that setting though…

M

1 Like

After uninstall some apps, it seems that Accuweather was responsible for the battery drain. I assume that it was trying to get my location with maps and then with wifi. Even when I did not allow this app to get my location.
Now without that app everything seems back to normal.
3-4% of battery lost overnight with flight mode on.

Hey

I update to 17.05.02 and also lost the parameter, even when seraching for it as before!

Sevan