Wifi doesn't work reliably

When my FP3 is connected to a Wifi, the connection sometimes just stops working. I have a good signal, but I can’t load a website or a YouTube video. The problem can be fixed temporarily by disabling Wifi and turning it back on, but this takes about 20sec each time, and often it stops working again after a few minutes. I had this problem in two different Wifi networks, and I only have this problem with my FP3, not with other devices.

Is this a known issue? Us there something I can do?

1 Like

Hi and welcome to the forum.

Could you check which band you are using 2.4GHz or 5Ghz.

24.GHz is the same band as bluetooth and sometimes I’ve had to disable bluetooth to connect.

So I use 5GHz which has a lower range. :frowning:

Thanks for your response. Unfortunately I’m already using the 5GHz band, so that can’t be the issue.

There are several threads around this topic, below 2 examples


I wonder what settings you have for the Wi-Fi could it be switching from 2.4 to 5 repeatedly?

  • what frequency band do you have the phone set to?
    Settings > Network and Internet > Wi-Fi >Wi-Fi preferences > Advanced > Wi-Fi frequency band
1 Like

It’s possible, the frequency band was set to “Automatic”. I now set it to “5 GHz only”. Let’s see if this will fix the problem :grinning:


If that works, and if any other equipment you’re using allows, then it might be better to limit the router to 5G, and maybe a specific channel, rather than limiting the phone. If you limit the phone to 5G, it would be unable to connect to other networks you’re in the habit of using on 2.4GHz, and you’d be forever adjusting settings.

1 Like

Update: Setting the frequency to 5GHz didn’t help, but setting it to 2.4GHz did! I haven’t had any issues for several hours.


In this case, you need to check what channel the router is using in the 5GHz band. If I remember correctly, you might want to manually set the channel (avoid channels above 112)1. Have a look round.

1Edit 2021-11-11 - I have now looked into this 5GHz channel question: see further down this thread. The 112 limit is certainly not applicable for all FP3s, In cases where it has been necessary, I think it’s likely a problem with the router rather than with the phone.


Do you still have 5GHz and 2.4GHz running on the router? If so can you get another person to try the 5G connection to see if the problem is with the router?

As previously mentioned you may like to check which 5Ghz channel was set on the router and you may be able to change that.

Good to know you have the phone working on wifi :slight_smile:

Yes, but I can’t change that myself. Also, it looks like all other devices are using the 2.4GHz band. I’ll check if the 5GHz band works on other devices. Thanks again for everyone’s help!


Well you’ll be all right as you are then, as long as you don’t need high bandwidth.

I had a similar problem to yours and just disabled 5GHz on the router. I should probably take my own advice and set a fixed channel towards the lower end of 5GHz! :upside_down_face:


Is it not your router to play with?

For the record, I ended up looking into this in a bit more detail, and I’ve put some ideas on Wifi together in another post here.
In this post I argue against the idea that 5GHz channels above 112 are in some way unsuitable for Fairphones (referred to in an earlier post in this thread). On the contrary, mine is now happily connected on channel 120 with a link speed of 433 Mbps.

It turned out, in my case, that the problem apparently had nothing to do with channel selection. It was to do with security settings. All my devices have now moved to 5GHz.

@LudwigStecher it’s possible this is your problem too, though if you aren’t able to check the router settings yourself, you might talk to the admin about it.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.