WiFi disconnects from a certain router every 1-2 minutes

Hey there,

I found some people having similar problems but not the exact same:
My FP2 (Lineage 1.41) disconncets constantly from my home wifi (Router: FAST5460 Wireless Voice Gateway, Firmware Version ). I tried reinstalling Lineage but it had no effect. The curious thing is that I have this problem ONLY at home and never in other networks or with mobile data. Neither does my laptop or other mobile phones have a problem in my network. So the problem should be between the FP/Lineage and my router (a friend of mine who also runs lineage has the same problem in my Wifi). I tried googling my router and the problem but couldn’t solve anything (I tried some stuff like changing the channel, the name, the password, I did a reboot etc).

Since this problem pretty much renders my fairphone uselss at home I would appreciate any kind of suggestion on how to fix this.

I hope / I assume it is not that easy (as you don’t have the issue in other Routers/WLANs) but I had some disconnect issues with a wrong “Keep Wi-Fi on during sleep” setting
(which can be found under
Settings -> Wifi -> [3-dot-menu] Advanced).

I use FP Open and not Lineage but I assume the settings are nearly similar.

Thanks for the response. Sadly playing with those settings had no effect. Maybe to be more precise: The dc also happens when I am using the phone ie I can hardly watch videos or stream something.

Can you please post log cat and kernel dmesg?



I tried getting them using the syslog-app. Hope this is what you need: https://we.tl/b76ZHAxcnD

all the best

I’m not sure, but I may have a similar issue in the normal FP OS. At home, most of the time my FP connects immediately to the WiFi. But after a short time, it seems the phone loses contact. Only when I wake the phone, it realises it lost connection and reconnects. Often, I have to manually go to the WiFi settings before it starts reconnecting.

Also, it’s often not visible I lost connection. The WiFi icon is on (although sometimes it also bears the exclamation mark), but the connection is down. Again, the phone only seems to “realise” this issue when I open the WiFi menu (see screenshot).

On my phone, this normally happens just once. After reconnecting, it works without much problems.

Anyone? Poroblem is still there and still only with my router :frowning:

Your router model FAST5460 has been offered by Vodafone Germany.

There are reports about malfunctioning devices that were exchanged by Vodafone in order to provide stable WLAN connections. (Google is your “friend”.)

If I were you, I would reset and reconfigure the router to determine whether the problem persists or not. If it does, it might be helpful to contact Vodafone directly and ask them to exchange this router as well.


Thnaks. Tried the factory reset and will now ask for a new router.

1 Like

Do you happen to have a Chromecast in your network? If yes, then the issue is Chromecast or Android devices able to cast. Wait for fix from Google via Play Store for all Android devices on Tue 18 Jan. Until then either on all Android devices

  1. Settings -> Google -> Cast Media Controls -> disable “Media controls for Cast devices”

  2. Disable WiFi; use Airplane mode; or use LTE only.

  3. Cut Chromecast from power, and optionally reboot router.

  4. Become a beta tester for Google Play Services and install that version


thanks for the replies. I don’t have a Chromecast or anything like it.

I had problems with my ISP (wanted to Dual Stack back instead of DS-Lite). They switched me and I had to reboot my router. I rebootet my router several times before and tried factory reset, like Gerry said.
However since that last reboot (or since I have IPv4 again) I had no DCs. Maybe this will helpful to someone. At least I guess we can conclude that it was a router issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.