English

Wifi detection issue

wifi
Tags: #<Tag:0x00007f9ff67e5188>

#1

Hi all,
Since a few weeks my FP2 cannot detect wifi anymore. As I try to activate it, it just says “no wifi available”. I’m guessing something might physically be broken inside, as I accidentally dropped it on the floor.
I tried to contact the support team but I’m still waiting for an answer…
Anyone knows which module is involved, or can help in any way ?
Thank you in advance!


#2

There are antana-connectors inside that are very fragile. Try pluging them back in, maybe this solves your issue. You can find that connector when you disassemble the core module. It’s that small antanna cable in the bottom left corner. Just unplug it and plug it back in.


#3

Thank you! I found the cable on the left yet I’m unable to unplug it without opening the small cover on top of it on the left. It’s not removable like the blue-cercled modules which I easily open with a regular PH0 screw-driver


#4

If you have the tools (torx screwdriver), you can try it. I have repaired Iphones, and if they have no WiFi, that’s a common problem (they use the same style connector. There is not much to go wrong, just remove the two screws by the Cam and top module and unclip the two metal clips and the plate comes off. Just be careful with the connector, it’s quite fragile. Also the fact that you dropped it indicates that this is the issue


#5

Thank you so much for your help. I have tried it but unfortunately it didnt change anything…


#6

There is always the possibility that some solder joint under the WiFi Module are cracked. This is NOT easy to fix and requires some hot air rework skills