WiFi connects and disconnects multiple times when enabling WiFi

Just as the the title says…

Say I had my phone on airplane mode, or just came home, and I enable WiFi connection, it will connect to the WiFi, and drop the connection within a second or three. Rinse and repeat a few times until finally, eventually, it stays connected. Never had any other device behave this way.

I’m at a loss… Seems there are a lot of little problems like this with these phones.

Any one have any idea what this one could be all about?

Haven’t experienced this issue with my Fairphone. Hopefully someone has an answer.

I do have devices that take a bit of time negotiating the Wi-Fi connection. Aka, find the saved network, connect, drop the connection while verifying the password / phrase for secured network and then show as connected again once this negotiation / process is complete …

Yea, I’ll take a video of it sometime. Not something I’ve experienced before with any other device.

1 Like

To take this further we’ll need:

  • phone OS version, Wi-Fi settings
  • router make, model, protocols and channels

Does this happen with all the Wi-Fi networks you use?

Latest, Android 12.

Happens to all WiFi networks, yeh, so I don’t think my router is the issue. Also, no other decide connecting to the same router does this.


I see you are using 2.4Ghz, can you try the 5 GHz or otherwise disable Bluetooth which uses the 2.4Ghz band

1 Like

Bluetooth is usually always disabled.

I use 2.4 GHz due to better range and legacy devices, so 5ghz isn’t really an option for me.

1 Like

Most routers are capable of emitting on both frequencies simultaneously. The choice is left to each device.

If this is happening with all the networks then perhaps you should contact official support contactsupport

I noticed you are using Device MAC instead of the default randomised MAC. Is there any special reason?


Uhhh… I can’t give you an answer to that. Don’t remember ever changing it.

Unfortunately, I having the same issue here…

When I have the issue, then my Fairphone connects and disconnect and so on…
In parallel I can connect to the guest WiFi across the same router. But then of course I do not have access to other resources in my privat network.
Some time I can work around while change the WiFi channel to a dedicated number but not too auto. Auto will then not work.
But today I checked all channels manual, with no result.
I disabled 2.4 and try with 5 Mhz only, but this does not help to. This is the same with 2.4 Mhz to.

So I am out of ideas!

Hi makol95

I saw your other post too. Are you experiencing this problem with all the Wi-Fi networks you attempt to connect to, or only your own private network (presumably at home?) If you are experiencing problems with all networks then I would advise you to #contactsupport

To take this further, could you indicate make and model of the router.

Could you set your router to automatic (default) configuration and post as much information as you can about the network characteristics: channels, frequencies, typical signal strengths, security (except don’t include private information such as SSID and password). I’m particularly interested to hear the security options being offered by the router (such as WPÄ3, WPA2, WPA, WPS, …) Also the use (or not) of TKIP.

I would recommend setting the router to use WPA2 or WPA3 without the possibility of using TKIP which in the past I have found to cause problems and which is deprecated anyway.

wlancfg {
wlancfg_version = 38;
country = “041”;
language = “en”;
bridge_mode = “bridge-none”;
auto_settings = 0;
auto_update = 1;
ap_enabled = 1;
ap_enabled_saved = 1;
ap_enabled_scnd = 1;
ap_enabled_thrd = 0;
ap_enabled_scnd_saved = 1;
ap_enabled_thrd_saved = 0;
channel = 0;
channel_scnd = 0;
channel_thrd = 0;
channelwidth = 1;
channelwidth_scnd = 2;
channelwidth_thrd = 1;
ssid = “";
ssid_scnd = "
ssid_thrd = “FRITZ!Box 7530 HO”;
hidden_ssid = 0;
power_level = 1;
bg_mode = 25;
bg_mode_scnd = 53;
bg_mode_thrd = 52;
user_isolation = 0;
encryption = 6;
pskvalue = “";
interval = 3600;
turbomode = no;
wlan_coexistence = 1;
mac_accesslist_state = 0;
event_control = 7;
band_steering = yes;
pmf_mode = 1;
pmf_mode_uplink = 1;
wlan_config_status = “”;
WDS_enabled = no;
WDS2_enabled = no;
WDS_hop = 0;
WDS_mac_master = 00:00:00:00:00:00;
WDS_mac_slave0 = 00:00:00:00:00:00;
WDS_mac_slave1 = 00:00:00:00:00:00;
WDS_mac_slave2 = 00:00:00:00:00:00;
WDS_mac_slave3 = 00:00:00:00:00:00;
WDS_encryption = 0;
WDS_key = “”;
WDS_ssid = “”;
night_time_control_enabled = no;
night_time_control_no_forced_off = yes;
night_time_control_with_reconnect = yes;
night_time_control_auto_update = yes;
guest_mode = 1;
guest_ssid_set = yes;
guest_ap_enabled = yes;
guest_timeout_active = no;
guest_timeout_minutes = 30;
guest_no_forced_off = no;
guest_ssid = "
guest_encryption = 6;
guest_pskvalue = "
guest_ap_auto_update = yes;
guest_user_isolation = yes;
greenmode_enabled = no;
IPTVoptimize = yes;
wireless_stickandsurf_enabled = no;
tx_autopower = no;
autochannel_plus = yes;
autochannel_plus_11a = no;
force_channel_conversion = no;
STA_configured = no;
STA_configured_scnd = no;
STA_configured_thrd = no;
STA_enabled = no;
STA_enabled_scnd = no;
STA_enabled_thrd = no;
STA_ssid = “”;
STA_ssid_scnd = “”;
STA_ssid_thrd = “”;
STA_mac_master = 00:00:00:00:00:00;
STA_mac_master_scnd = 00:00:00:00:00:00;
STA_mac_master_thrd = 00:00:00:00:00:00;
STA_encryption = 0;
STA_encryption_scnd = 0;
STA_encryption_thrd = 0;
STA_pskvalue = “”;
STA_pskvalue_scnd = “”;
STA_pskvalue_thrd = “”;
STA_mode = 0;
STA_mode_scnd = 0;
STA_mode_thrd = 0;
STA_overwrite_ap_config = yes;
STA_repeating_mode = 0;
uapsd_supported = no;
uapsd_enable = no;
wmm_enabled = yes;
wmm_supported = yes;
wmm_ap_aifsn = 10;
wmm_ap_ecwmin = 3;
wmm_ap_ecwmax = 7;
wmm_ap_txop = 1;
wmm_ap_ackpolicy = no;
wmm_sta_aifsn = 10;
wmm_sta_ecwmin = 3;
wmm_sta_ecwmax = 7;
wmm_sta_txop = 1;
wmm_sta_ackpolicy = no;
wps_enable = yes;
wps_devicename = “FBox”;
wps_uuid = "
wps_version = 16;
wps_config_methods_supported = “PushButton”;
wps_config_methods_enabled = “PushButton”;
wps_setup_locked_state = “Unlocked”;
wps_setup_lock = no;
wps_configuration_state = “Configured”;
wps_last_configuration_error = “NoError”;
wps_registrar_number_of_entries = 0;
wps_registrar_established = no;
wps_registrar_enable = no;
wps_registrar_uuid = “”;
wps_registrar_devicename = “”;
wps_guest_uuid = “********************************************”;
feature_wlan_coexistence = -1;
debug_settings {
trace_state = wlancfg_trace_state_off;
trace_parameter = “”;
client_stations {
mac = 44:C3:06:10:0F:87;
type = 1;
} {
mac = 38:BA:F8:29:8E:9D;
type = 1;
} {
mac = FE:39:6F:FD:7B:7B;
type = 1;
} {
mac = FE:39:6F:FD:7B:7A;
type = 1;
} {
mac = 66:BA:3B:00:AB:B1;
type = 1;
} {
mac = C0:EE:FB:E6:52:36;
type = 1;
} {
mac = E0:E6:2E:9D:DE:B8;
type = 1;
radios {
id = 1;
band = wlancfg_radio_band_2_ghz;
channel = 0;
autochannel_plus = yes;
autochannel_plus_11a = no;
} {
id = 2;
band = wlancfg_radio_band_5_ghz;
channel = 0;
autochannel_plus = yes;
autochannel_plus_11a = no;
acl_config {
autofill_enable = no;

So, these are the actual Wi-Fi settings…
Router model is a Fritz!Box 7530.

Well, we’ve had issues with the Fritzbox 7530 before, though that was with the FP3, I don’t recall having seen similar problems with the FP4.

A common solution back in the day was to manually set the 5 GHz channel to a low number like 36. Give the 5 GHz channel a different SSID from the 2.4 GHz so that you can leave the phone to accept either band but force use of the one or the other by selecting the appropriate SSID.

Further reading.

Hi OldRoutard

Thank you for this feedback.
I did that change you suggested right now. But this does not change anything.
So I now have a separate SSID for 2.4 and 5 GHz and I switched the channel for 5 GHz to 36. But the phone can still only connect to the guest net but not to 5 and as well not to 2.4 GHz of my internal network.

So it looks like your suggestion is not a fusible option.
And for my It is not an option to change the Channels manual till the phone can connect, every time I do have this issue. This should be something which should be fixed with a firmware update.
Remember, my Fairphone is the only one, who can not handle the network situation. All other mobile devices do not have this issue.
And it looks like, that this issue occurs, when a high number of Wi-Fi devices are around. But I do not have a control over this.

I did an additional check on the used channels in 2.4 and as well in 5 GHz. My Router is currently the only device which offers a 5 GHz connection. But the Fairphone is still not able to use it. So it looks like that the Fairphone is not able to connect to 5 GHz at all.

Thanks for your feedback.

Although I use an FP3 I note it can take a while to recognise the 5GHz signal whereas the 2.4Ghz is recognised almost immediately

I’m not very surprised the SSID separation didn’t help.

As already stated above, it sounds to me as though there is some problem with the phone itself. Other FP4s function perfectly well with both 5 GHz and 2.4.

This might also indicate that there is some problem with the security. I’ll give it some thought, but I think you would do well to contact official Fairphone support.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.