Wifi Connection Failure on various public networks

Recently I am havng problems connecting to open public wifis (not the EAP wifi I posted about before), intially Swisscom stopped working about 2 weeks ago, now More wifi networks are failing for me, I wonder if some updates are being rolled out that the FP2 is incompatible with.

I onyl have this issue with FP2s, any other phone I’ve tried, or PC connects to the same public wifis with no problems. I have two FP2s and both behave the same, I reset one to factory standard and reverted to an older android but no difference.

The behaviour is that the phone sees the SSID but tapping on it and selecting ‘connect’ causes the ssid to briefly display ‘Connecting…’ then changes to ‘Saved’ It seems to keep trying to make the connection. Eventually the text under the ssid will display ‘Wifi Connection Failure’ with no more details. Very very very infrequently it will connect, there seems to be no pattern to when a connection will be successful. I test this mostly with the Swisscom wifi which is available all over switerland and should be.

Anyone have any similar experiences/solutions

So your phone only has troubles with public networks not your home network.

Just a guess, but maybe it is a DNS related problem?

Hi, yes only with what appears to be an increasing number of public networks, home and friends have been fine. The phone doesn’t get as far as making a connection though how could DNS be a factor?

I should say, also tried 2.5g and 5g only but no difference.

And then it just worked, both phones started connecting with no problems, since i started posting I installed open OS on one of the FP2s and it couldn’t connect either. Then one day they both started working, clearly something related to the infrastructure has changed, wish I knew what, but there is something about the FP2 that is sensitive to a network configuration that other phones don’t mind.

1 Like

It may look like you are connected to a network but as you start to access all starts to fail with no obvious reason.
Maybe some destinations still work while most will result in connection errors.
A total network failure is common though.

I had a DNS problems some time ago as I switched home routers. It wasn´t with my phone but e-reader. It connected, but the connection was unstable and broke permanently. I needed a moment to find the cause as I usually assign fixed ip addresses and DNS servers.
I switched wifi devices from a Logilink to a Fritzbox router. I adjusted the gateway but forgot to adjust the DNS server addresses for the e-reader. So the connection was established but permanently broke until I also adjusted the DNS server addresses.
My idea in your case is, it could be that your phones were registered to public network and something was altered (like new public DNS addresses or something). Your registration was still available on your phone but outdated needing to be refreshed.
This usually is done when deleting and registering the network again.
But could also be done by some kind of command line (corresponding to dos ipconfig /flushdns).

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.