WiFI calling on Virgin UK FP4

Searching the Settings app for calling

WiFi calling options in the notifications bar is disabled

I’m sorry for jumping in this conversation (I’m not in UK), but I have the same problem with Vodafone CZ. No Wifi calling settings. Wifi calling top menu icon greyed out.

However, now I can confirm that when I switch to airplane and enable wifi, I can actually receive SMS and make phone calls.

I’ve found one way to check whether this “hidden wifi calling mode” is active.

If you draw from the top to display settings, you don’t know anything:

However, if you swipe down once more to show the two-row quick settings, the network name is actually there in the upper right corner!

When this mode is active, you also get the wifi calling icon next to your contacts in the phone app:

If you have a decent linux router at home through which your phone is connected, you can also try running this command on it to see whether some Wifi calling traffic is actually flowing through it:

 tcpdump -i YOUR_ROUTERS_BRIDGE_INTERFACE esp or udp port 4500 or udp port 500

It should show a burst of packets as soon as you switch to airplane and connect the phone to the wifi. If not, then your wifi calling is doomed :slight_smile:

This is how the first few lines look for me:

02:31:40.041010 IP 192.168.1.186.42074 > epdg.epc.mnc003.mcc230.pub.3gppnetwork.org.500: isakmp: parent_sa ikev2_init[I]
02:31:40.056339 IP epdg.epc.mnc003.mcc230.pub.3gppnetwork.org.500 > 192.168.1.186.42074: isakmp: parent_sa ikev2_init[R]
02:31:40.119342 IP 192.168.1.186.42074 > epdg.epc.mnc003.mcc230.pub.3gppnetwork.org.4500: NONESP-encap: isakmp: child_sa  ikev2_auth[I]
02:31:40.285068 IP epdg.epc.mnc003.mcc230.pub.3gppnetwork.org.4500 > 192.168.1.186.42074: NONESP-encap: isakmp: child_sa  ikev2_auth[R]

What’s interesting is that when I’m in this “hidden wifi calling mode”, IMS service status (call *#* #4636 #*#*, choose IMS status from the three-dot menu) says registered. But when I switch off airplane mode, it says not registered. Now this is something I’m gonna #contactsupport about.

IMS service status in the hidden wifi calling mode:

IMS service status when connected via normal mobile network:

What’s good is that if I switch the phone to airplane and reboot, the phone does not need to connect the mobile service to be able to go into this hidden wifi calling mode. Not even once. So the provisioning from the network is probably only one-time and then it works always.

I’m not sure, however, if the operator does not want to somehow register each Wifi calling-capable router/site via the mobile network. That could mean that places which have no reception could not have wifi calling enabled. But that’s pure speculation from my side. A crazy idea could be to take your home router, take it someplace with reception and connect an Ethernet cable with a quality link to the internet :slight_smile:

3 Likes

I would also contact provider Support, as this seem to be connected to the provider used…

Did that, the result was quite funny. Vodafone said the next step is on Fairphone. Fairphone said the next step is on Vodafone… Hmm, chicken and egg? :slight_smile:

Yeah not a big surprise🙃 as annoying as it is, I think pushing also the provider still is a good thing to do, as seen here e.g. inside knowledge is different to outside communication

Something is a bit off as I have two FP3s

One EE with contract as explained that I had to enable via getting a signal initially
One with a PAYG O2 sim that doesn’t provide W-Fi calling

However when searching for ‘calling’ on each phone I get the same results as the screen shot below ???

What OS and version are you using?

Have you tried a Safe mode start or a factory reset?



Those screenshots are from a pretty new FP4 running the stock OS. As per my previous posts I know WiFi calling fundamentally works, I just don’t have any options for it and the phone doesn’t use it unless I force it via disabling mobile network access. Like @peci1 I can view the 3gppnetwork access in my WiFi routers DNS logs, which also reinforces the fact that under the hood WiFi calling is enabled. It’s just not quite right.

With respect @amoun you’re talking about a different handset to the subject of this thread, which is not helpful!

1 Like

Although you are correct in that I am using the FP3 both the FP3 and the FP4 are using the the FOS Android 11

#Will check with my daughter’s FP4 to see if my screenshot is of the mark and remove it if it is.

Thanks for your concern

1 Like

I think the device can make a difference in that it might be maintained differently by the provider so it might be the FP3 shows different settings with the same provider than the FP4, although both are Android 11. Is EE = Virgin or smarty if not its also difficult to compare, as its just not the same device plus a different provider.

1 Like

After raising the query here on this forum and being pretty confused, i have been doing my own research. I am not technical, so I could be wrong here, but what I have gathered is that each individual network has to support each specific handset model in order for Wi-Fi calling to be guaranteed to work correctly. In the case of the Fairphone 4, and in the UK, only Vodafone supports the Fairphone 4 for wi-fi calling currently and I have since had this confirmed by Fairphone tech support.

So, if you have managed to make wifi calling on your Fairphone 4 work in the Uk with Virgin or Three (Smarty) then good for you, but I have just taken the plunge on switching networks to Vodafone as I can’t carry on without guaranteed access to this functionality. I have no loyalty to my current network (let’s face it, they have zero loyalty to me), but I am going to have to spend an extra £5 a month for this which I could do without and am now tied to a 24 month contract so I can’t just switch back instantly if another network make this available.

It’s the little things like this that make switching to Fairphone an act of faith, but it’s one I am committed to on principle.

That is incorrect :; in that my daughter has an FP4 and uses EE when visiting me, Plusnet when visiting her mother, and some other Talktalk when at home in Bristol

  • Faiphone have a working relationship with Vodafone and they therefore promote each other ~ note there have been a lot of issues with Vodafone on the continent ~ search this forum

  • That a carrier supports a phone means they have a regular recognition of a particular phone. When I called EE on receipt of my FP3, they didn’t recognise it but suggested I go find and a place to pick up a good network connection EE as it has to be enabled over the network. Following that the Wi-Fi option became available, that was two years ago ~ no problem

Well, like I said I am not a technical expert, but it is what the Fairphone tech support told me and I was not able to make it work with Three and not prepared to take a chance with getting another network SIM card only to find it didn’t work. So, what I would suggest to others is that they can try your method and see if it works, but if it doesn’t and they need WiFi calling then the only guaranteed way to make sure it works with their Fairphone 4 is to switch to Vodafone for the time being.

This a bit old but just to confirm that the FP4 in the UK does Wi-Fi calling using EE still as of March 2023

I have a recent FP4 bought direct from Fairphone with 02 monthly contract eSIM and an EE PAYG physical SIM.
Both O2 and EE networks claim to support WiFi Calling and there is an option in settings to enable WiFi calling for each SIM.
If I choose the option to prefer WiFi calling then the WiFi calling symbol shows on the status bar for EE but not O2.
WiFi calling is set ON in my MyO2 web account for the device.
I’ve seen reports elsewhere that WiFi calling only works for android devices with O2 branded firmware - so perhaps this is a commercial issue rather than a technical capability one.
The plot thickens …

Are you running the latest firmware? There was a WiFi calling update on either the most recent release or the one before that which updated the settings and it’s worked perfectly for me since then

I’ve accepted a recent firmware update - what is the latest version? Meanwhile I’ve alo tested it with a physical Three PAYG SIM and that shows WiFi Calling icon in statuis bar OK. So looks like it might just be O2 (for me at least) …

I’ve switched to Virgin (O2) and the wifi calling options are missing under Mobile network.
I added them from Dev options.
They now show but never “engage”. I can set wifi calling on, but the moment I leave the screen it turns off again.
I’ve phoned Customer support on 789 and asked them to enable wifi calling on my SIM.

It should all work and yet it isn’t.

I’ve just accepted the FP4 Android 13 update and the WiFi calling icon now appears for O2 when it’s set with WiFi calling on and the make calls over WiFi option is selected, time will tell if it actually works …