WiFi/Bluetooth problem

Hello,

I’m on the 2,4ghz network on my Fritzbox 7490. I noticed that when I connect Bluetooth headphones the wifi disconnects. It is really annoying when you calling and want to switch to headphones then it disconnects wifi and ends the call. I have to say I can’t use the 5ghz network because it doesn’t work as good as the 2,4ghz.

Is there a workaround or solution for this problem?

Sadly I have the same issue with other devices. I have my phone on 5Ghz. I have a computer that only does 2.54Ghz so I have bluetooth off unless I intend to use it.

So with anything locked to 5GHz it’s fine but if I want to use bluetooth on my 6 year old tablet I have to switch of the Wi-Fi

What you can do maybe is to check which channles the headphones use, it will be shown on the Fritzbox then set the 2.4Ghz on the Fritzbox to a specific channel well away from what the headphones use.

Note 4G networks and microwave cookers also use the 2.4GHz band, so there still possible interference.

Are you sure about the 5Ghz not being viable, distance is an issue, but otherwise it should be fine.

You can separate the two chanels on the Fritzbox i.e. Fritz2_4 and Fritz5 then it is easier to select from any connecting device, else devices will search for the ‘better’ signal and may push each other around and out the door.

1 Like

Bluetooth has a near perfect solution against interference, frequency hopping. Your WiFi also has an option to enable auto channels. Make sure it’s enabled. Fritzbox is a good brand, they should have good algorithms for it. I have a house full of Fritzbox APs. No issues.

Here are some examples of configs you should check.

1 Like

Thanks guy’s. The problem is that I limited to use only the 2,4ghz WiFi. When I use both and enable the handover between that two or even only use 5ghz with seperate SSID’s than my Fairphone always loses the connection.

When using only the 2,4ghz my connection is stable.

That seems to be an issue again and again, but still you could check if your 2.4 GHz network picks the channel within the 2.4 GHz band automatically (Auto channel) as proposed by @UPPERCASE . If it doesn’t chances are even higher that your WiFi is operating on a channel that is used by too many other WiFi networks. For instance this is what it looks like for my Fritzbox:

Even then, Bluetooth is pretty good at handling busy areas. Because it was designed to work with many devices in the same area.

This is a really strange issue that must have some other contributing factors.
My household has:
FP3, FP4, 2.4 and 5 GHz WiFi, microwave oven and often multiple active Bluetooth headphones/speakers. Not once have I seen the problems described above. Bluetooth is stable and WiFi as well. How sure are you that your problems are directly related to the Bluetooth connection? Have you tried different Bluetooth devices? Maybe one of them produces unusual interference?
First of all I’d also check the WiFi channels as already suggested above.

2 Likes

I never got a stable 5GHz with my FP3/FP4. Have constant interruptions while all other devices are working on the 5GHz network.
I don’t know if Fairphone has a driver problem, but it’s not nice. That’s why only 2.4Ghz for me.

Steven

However it seems mainly in combination with AVM, I never had issues with my Speedport and Fairphone…never had to split SSIDs or fix the channel to a lower one

This topic is a Wi-Fi/Bluetooth issue which I have and is generally a 2.4GHz conflict or interuption and would have nothing to do with 5GHz.

So maybe another topic would suit better ?

Ah yes, you are right.

1 Like