Widevine DRM is missing in Fairphone Open 18.10.0 (Android 7.1.2)


I just updated to Fairphone Open 18.09.2 which worked fine.

However I do not have Widevine DRM available anymore. I checked with DRM Info (https://play.google.com/store/apps/details?id=com.androidfung.drminfo&hl=de) which shows me only ClearKey CDM nothing else.

Can anyone confirm this? Is the same issue present for Fairphone OS 18.09.2?

Thanks for any help

Fairphone OS 18.09.2 has both ClearKey and Widevine:


Sorry I was wrong, the Fairphone Open version number is 18.10.0 (https://code.fairphone.com/projects/fairphone-2-official-releases.html)

Widevine is missing here. Maybe this is a Fairphone open related issue.

I have GApps Mini installed.

I recently upgraded my FP2 to the release 18.10.0 and I faced the same issue regarding the missing DRM.

I started an issue in the Fairphone Issue tracker: https://bugtracker.fairphone.com/project/fairphone-android-7/issue/79

In case you share this problem you may vote for this issue.


@ChuckMorris: Which Widevine Level do you have with Fairphone OS? L1 or L3?

I can’t see it on your screenshot

Since our lovely Fairphone support reject the bugtracker issue without any explanation (Thanks Team FP) here is a solution I found on the forum which worked for me with FP Open 18.10.0

This has been fixed for lineageOS: https://bugtracker.fairphone.com/project/fairphone-lineageos-on-fairphone/issue/22

However I have no idea why Fairphone does not seem interested or able to fix this for their own OS!

I hope this helps other people.


“We cannot distribute the proprietary blobs for Widevine on Fairphone Open, sorry.”

… for now doesn’t sound like ill will, more like legal constraints.

What a community does with its community Android port is a whole different matter.



(A “Device Unique ID” is displayed right above the Security Level so I choose not to show that section in the screenshot.)

Just for archival purpose: on LineageOS + microG I also have both, and L3.


would it be possible to get more details on how to install these items? E.g. a step-by-step explanation?

I am not really used to install anything in the system directory but missing the widevine for an app.

Thanks! :slight_smile:

Hi Julia,

sry for the late answer

Here is a rough step by step description:

  • Frist get ADB working: see this description: https://www.xda-developers.com/install-adb-windows-macos-linux/
  • copy the files to folder on your internal data storage (e.g. /data/local/tmp): use either of these options:
    a) download them directly to your phone using the links in this thread
    b) you can just use your normal USB connection and your file expolorer to copy the files
    c) or you can use ADB:
    • ./adb push libWVStreamControlAPI_L3.so /data/local/tmp
    • ./adb push libwvdrm_L3.so /data/local/tmp
    • ./adb push libwvdrmengine.so /data/local/tmp
  • Open a ADB connection to your phone and mount system partition as read-write :
    • ./adb shell
    • su
    • mount -o rw,remount /system
  • Now copy the files from your temporary storage on your data partition to your system partition :
    • cp /data/local/tmp/libWVStreamControlAPI_L3.so /system/vendor/lib
    • cp /data/local/tmp/libwvdrm_L3.so /system/vendor/lib
    • cp /data/local/tmp/libwvdrmengine.so /system/vendor/lib/mediadrm/
  • Adjust the permissions on the files for root:
    • cd /system/vendor/lib
    • chmod 644 libWVStreamControlAPI_L3.so
    • chown root:root libWVStreamControlAPI_L3.so
    • chmod 644 libwvdrm_L3.so
    • chown root:root libwvdrm_L3.so
    • chmod 644 mediadrm/libwvdrmengine.so
    • chown root:root mediadrm/libwvdrmengine.so
  • Remount system partition as read only and exit
    • cd ~
    • mount -o ro,remount /system
    • exit

I hope this helps you to get your Widevine to work with fairphone Open :slight_smile:


Thanks a lot! It works! :slightly_smiling_face:

For all others who try and do not have experience: I only managed way c)

Hello thank you for this tip…
Is it possible to do the same job using amaze to copy the files and using the terminal to adjust the permission ? I think so… But i don’t dare trying… afraid to kill my system…
Sorry for my bad english…

Eventually i have used twrp…
I downloaded the file directly on the phone.
I moved them with the app “amaze”
i restarted in recovery mode with twrp. Usins twrp’s terminal i changed the permissions.
And it works !!!
Thanks again for this topic !!


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.