Wi-fi problem Telekom speedport 3

I have previously solved a WiFi connection problem, choosing manually the frequency to connect (5 GHz) to the router. However, now the option to manually select the frequency is not present anymore in the WiFi settings of the FP3, and the problem is back. So, the phone shows that it’s connected, but it is not, or at least, it is continuously breaking. For example, I cannot even call on WhatsApp, the call doesn’t go through. However, I can do it with data. Any solutions? Thanks

Yes that option has disappeared with the A11 update.

May not be a Telekom issue

What I have done is to have different SSIDs for each band and then set the 5G to auto-connect and not the 2.4Gz, so the phone will always connect to 5G

However like you I have found the 5G connection very unstable even if within a metre or two of the router, so I have switched the auto to 2.4Ghz

How do you choose, to which frequency is the FP3 connecting?

Give different SSIDs to the 5GHz and 2.4GHz

Then Settings > Network and Internet > W-Fi

You will now have two choices

For each go to their settings, the little cog to the right
Then Advanced >
and select Auto-connect ON for the one you want
and Auto-connect OFF for the other