Wi-fi and mobile internet connection issues - and maybe also esim

Hi everyone,

I am wondering whether anyone else has this issue and whether you found a solution.

Since a few days, I am having serious issues connecting to wifi and mobile internet. It connects for a moment and then disconnects - displaying a wifi or 4G connection with a small ‘x’ at the bottom. I have had this problem with 2 simcards and with various wifi (as I am traveling at the moment). I have already tried resetting the connections, resettings APNs, restarting phone after each step, switching simcards around, etc.

I do not know whether it is related, but I have an esim (from esim.me) to allow for easy simcards while traveling. I can switch off my regular sim, but since a few days (since I left one country whereI used an esim) I cannot switch off the other simcard anymore. I have tried switching them around to see if it was a simcard slot issue, but when switching I can still switch off my regular simcard and not my esimcard. Also through the esim.me app it doesn’t seem to recognise the card anymore.
The 2 issues seem to potentially be related, however I realise that I have actually been having wifi issues for a few months and frequently resorted to using my mobile internet instead.

I hope someone might recognise this and could help.

I wonder about the e-sim. As I never heard that the Fairphone 3 was capable to use a e-sim.

I believe there are physical cards that can be used to “materialize” e-SIMs. If I understand aright, Megin has been using such a physical card to quickly and easily swap e-SIMS when moving from one country to another.

3 Likes

they tried to get it working on the FP2 as well

2 Likes

As to @Megin 's actual problem, the quickest might be to remove both SIM cards and do a network reset.

Before that though, you might try emptying the esim.me app cache and deleting the data (I presume this can be done without actually losing the connectivity rights, as long as you have the relevant data to start again).

2 Likes