English

Why use Fairphone's Kitkat Alpha (4.4.2) instead of Chris Hoffmann's 4.4.4?

Continuing the discussion from :pencil2: µG Unified Nlp (with Installation Guide):

@chrmhoffmann helped with the official Kitkat Alpha so his expertise went into it. Besides the latest build is from 22.11.2016 (see Settings -> About phone), whereas the latest unofficial build is from May 2016.

1 Like

OK, so it is better to use official Kitkat Alpha. The clitches in Osmand I had experienced in both KitKat versions. Do you have the same problem?

I tend towards switching back to 4.2.2. because Media Storage doesn’t seem to be able to deal well with my big music collection (140 GB) under 4.4.2. I just installed a different music app (Vanilla Music) and just like the default music app, its interface (not playback!) keeps freezing.

I had better experiences using GPS under the 4,2,2 than 4,4,2 . That’s a good reason I feel.

1 Like

Yea, that is my experience too that 4.2.2 works better concerning GPS.

I fiddled a little bit around and found out that the instability only occur under certain conditions, for example glitches of the blue arrow occur only in navigation mode not in bicycle viewing mode. It seems like there is a performance/optimization problem.

My assumption is that Stefan do not experience this bug because he have a FP1(U), as far as I know the 4.4.x development was done with an FP1(U) but I have an FP1 from the first batch. urs_lesse and joergschulz which phone do you use FP1 or FP1(U)?

FP1U

(20 characters)

1 Like

Mine says Fairphone First Edition on the back cover. I think the only* difference between FP1 and FP1U is the storage layout, which was unified by default for the latter. The former can be upgraded making it a de-facto FP1U.

*Ok, yeah, there is a small version change of the chipset, but as I said above, I do have a FP1.

1 Like

What do you mean with “20 characters”?

That is just filling to reach the minimum length for a post – 20 characters. “FP1U” is too short. :wink:

1 Like

O.K. 20 charactersssssssssssss

3 Likes

Exact this version change is what I meant. I unified the storage layout of my FP1 long a go. But my FP1 have this older chip set Version, since my FP1 is from the first batch (Auf das
"3 years of Fairphone 1" Abzeichen schiel). And now I learned you have the same old chip set but your phone have no OsmAnd glitches, Hmm I’ am stumped. Do you use the F-Droid OsmAnd version?

1 Like

I’m using FP1U without any osmand issues except that the whole thing gets slower and slower - possibly waiting for a reset.

1 Like

I use the FP1U with the latest original OS, 4.2.2, and do not experience any problems with my GPS or OsmAnd (F-Droid). It just slow, like @joergschulz noticed also. But I guess this is a processor problem, the FP1 is just getting old for these new programs…

Thanks, for your comment. As I stated above this is exacly my experience too. But the problems occure when it comes to OS 4.4.2 or 4.4.4.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.