(Why) Do I need Network-based location? (specifically: µG UnifiedNlp)

Did you configure the backends and reboot afterwards?
Oh and did you set location mode to high accuracy?

I don’t think those two unchecked points are relevant for Signal though. :confused:

I think it’s ok to leave it as a separate topic, so others with the same question can find it faster.

hey, thanks! (i knew that much but it’s nice to have it here for future readers :slight_smile: )

@paulakreuzer: i now additionally set up the Openbmap backend and both this and the GMS one use offline databases. (edit) And yes, I rebooted after setting them up. (/edit) They obviously work, as I get an instant rough fix in osmand and a bit later the gps localizes me more accurately. also UnifiedNlp says that location backends are set up.

I just realize: I did not do the step with the signature spoofing, since on the µG website they do not mention this (and everything installed fine without it). But could this be the problem afer all? Or was this a step that was formerly required to get µG installed?

edit2: just to be clear. there’s 2 issues here. the first one is that the self-check of UnifiedNlp does not see any location (although satstat and osmand do) and the second one is that i cannot use signal (it complains at the point where you register your phone number).

1 Like

It is a step needed for apps like Poke Mongo. I don’t know if it’s needed for Signal.

If you get a location in OSMand with location mode to energy saving, than you can ignore this.

yes, this also works.

ugh, i think it’s the signature thingy then. this looks like a big hassle. first get root then lose it… hmmm. well i’ll give it a try.

do you know whether i will be able to use the FP Open Updater afterwards? (Or do I need to do this whole procedure (or is this only for XPosed?))

The guide looks more complicated than it is and contains some points that are only needed for specific modifications.
Basically you’ll just have to flash everything you flashed before via TWRP again.

For microG to impersonate Google Services, it needs signature spoofing. Just use Tingle.

To know more about the Android security model, or why this is needed, check other posts of mine like this one quoted below:

Sadly, Signal and other bunch of free apps depend on crappy proprietary GMS to work.

About your update concerns, Tingle patch (i.e. modifies) the system, so when you update the system to a newer, pristine version of FP Open, you’ll need to patch it again. But so far, you won’t have any other problem with the Fairphone Updater.


and will i have to remove tingle before being able to update or just reinstall after the update?

also, i was wondering – is it only necessary for the installation of the app? because then i could also install it and forget about it (after the next update) :slight_smile:

Nop, you can update without reverting your modifications, but you lose them.

As of now (current Android state), you can install any app on the ecosystem (this wasn’t true some years ago). On runtime, those apps check if you have Google services, or a reimplementation like microG, and they use them if available. If not, then can occur two things:

  • The app crashes, when initializing or at some step (Signal’s registration)
  • The app shows an avoidable message of "lack of GMS” and can’t use some functions (usually push messages, so you don’t get notifications on Slack or Signal)

You can patch the system with Tingle, install microG, register on Signal, and update the system eventually. Then you can use Signal because you are already logged in, but you won’t receive push notifications.

Privacy note: microG still contact the Google Push Messaging servers and Google receive a bunch of metadata of your communications. However, with microG you can control that with the relatively new push messaging settings and by inspecting the code, which is completely open source.


hey @Roboe, thanks for all your replies and info again! :slight_smile:

so i will need to keep signature spoofing even after the signal registration :\

I just tried to use tingle and I am getting “ERROR: No device detected! Please connect your device first.” after selecting option 1 (after running “python3 main.py”).
I already tried to change the “connected as”-option of the phone (MTP, PTP, mount sd card) but nothing worked. usb debugging is enabled and i allowed root access for adb.

– does anybody have an idea what could be the problem? (@ale5000?)

1 Like

ok, i found it :stuck_out_tongue:

i needed to add my phone ID to ~/.android/adb_usb.ini
(see here – unfortunately only in german)

–> find it via “lsusb” (run it, disconnect the phone, run it again – you see which ID is missing, that was the phone ;))

add “0x” + the first 4 characters of the ID (before the colon)
so, e.g. “0x1234” to the file (create it if it does not exist)

adb doesn’t work if you have any of these USB modes enabled, in my case. Just disable the one you have enabled (uncheck the active tick) to clear a path to ADB to work

@jme: It should have something to do with usb debugging not enabled correctly or missing drivers in the pc.

Does your pc see the phone and is it able to navigate in the phone?
Does your phone display a notification of usb debugging enabled?

1 Like

it works now (se above) … the phone was still in PTP mode… so that was ok :wink:

hey, thanks for the instant reply! :slight_smile:
i figured it out – see above. needed to add my phone id for adb to work first.

1 Like

Thank you for the creative solution! That was something new here in the forum, I think.

yeah, well… signal still does not work.
the tingle patching reported that it was successful – so i guess it must be the issue from above: UnifiedNlp’s self-check does not have a known location :frowning:

You need microG Services Core, not UnifiedNLP. The latter is only for location services, the former replaces more Google services. Add the microG’s repo to F-Droid:

And update to the latest microG Services Core:

1 Like

i installed microG from fdroid according to the abovementioned guide (5.5).

there it says

Install the latest
*microG Services Core
:exclamation: may be called “µg UnifiedNlp (no GAPPS)” instead, but make sure it displays “microg” and not “F-Droid” as the repository.
*microG Services Framework Proxy

  • and at least one Unified NLP backend (from F-Droid repository).

I did all of this. Do I still need to install the apk from their website? (i.e. your link)
If yes, then our guide should be updated.

Just be sure to have version 0.2.4-39 or higher

1 Like

Enable the Google device registration from microG Settings and try again, maybe?