Manually install Fairphone OS for the Fairphone not working

I’ve tryed using Fastboot on linux, and also on Windows 7. My device is not detected:weary:
I’ve tryed also installing dyrectly from sd card… Both the manual switcher and the ota image… It does not work. Tryed also updating TWRP to 3.2.
I have no idea what else to do. Please, some help? The support team requires me to go back to fairphone os because of the rebootings issue.

I’ve used this tutorial also:

Thanks a lot!

Did you put your phone into #dic:fastboot mode? Do you use a data cable?

What those files are to be opened with the updater app afaik and they are for updating or for switching from Open OS. What OS are you on right now?

1 Like

Since Android 7, Fairphone no longer provide OTA images for Fairphone OS which you could install with TWRP.
(And it was a real hassle before anyway compared to Fairphone Open OS. The manual installation worked much better for Fairphone OS.)

So you need to get fastboot running.
Have you tried Google’s platform tools for this? …

If you got fastboot running, Fairphone’s guide for manually installing Fairphone OS should work.

Yes, I did. And I have used 3 different cables, all of them data cable

Opening with yhe updater app gives a message: “Restart your phone to complete the update”.
But touching the “RESTART” does nothing, and a manual restarting neither does.

Fairphone Open OS, Android 7.1.2

Thanks, Paula!

Hi and thanks!
I have Android SDK Platform-tools installed from Ubuntu repos

Then you don’t need to go back to FPOS for support. FP Open OS is officially supported by Fairphone - the support employee who told you that must be mistaken.

Not necessarily.
If the reboots would be gone in Fairphone OS, it would hint towards software.
If the reboots would be the same or similar in Fairphone OS, it would hint towards hardware.
No definite proof either way, but a strong hint.

That they support Fairphone Open OS does not mean they couldn’t use Fairphone OS to troubleshoot it.

Maybe, but as long as no FP Open specific bug causing reboots is known this would be a high effort to require from the user.

I agree with both of you. If Open OS is an official OS it may be supported by the Fairphone team. I will write back them.
But if they want me to give a chance to Fairphone OS to troubleshoot i can do this… if easy!!
Some other idea on how to make the manual switcher or the installer work?

Hello again. I have done this:

But the terminal does nothing :roll_eyes: :

matariles@matariles-Lenovo-ideapad-520-15IKB:~$ sudo fastboot devices
[sudo] contrasenya per a matariles:
matariles@matariles-Lenovo-ideapad-520-15IKB:~$ /usr/bin/fastboot devices

Previously I did also:


matariles@matariles-Lenovo-ideapad-520-15IKB:~/Baixades/fp2-gms-18.09.2-manual$ sudo sh
[sudo] contrasenya per a matariles:
** Fairphone OS 18.09.2 Manual Flashing Script **

Validating files…
Validation complete.

WARNING: No Fairphone 2 found in fastboot mode.
WARNING: Make sure that a Fairphone 2 is connected.
WARNING: To check for devices, type ‘/usr/bin/fastboot devices’.

matariles@matariles-Lenovo-ideapad-520-15IKB:~$ adb devices
List of devices attached

I have the Phone rooted and usb debugging activated. Maybe it’s not important in fastboot but there is no chance to change from charging mode to MTP transfer mode. Does nothing…
Any advice, please?

Just to clarify …
Are you trying to use fastboot with Android booted and running?
That’s not how it works.

With Android booted and USB debugging enabled, you can try adb … adb devices should give an ID then.

For fastboot to work you have to boot the phone into fastboot mode by starting or rebooting it with Volume - pressed until the Fairphone logo is shown.

1 Like

Thanks, AnotherElk. No, no, I dit it well. Fastboot in fastboot mode and adb with the phone booted, as you say

1 Like

Well, the support team can’t help me more. Next step i to send back the phone to repair. But I’d like to try fairphone os before, just to be sure that random reboots are still there or not. Do you think that is this possible?

Hi @Raul, not sure whether this is the issue, but might be worth a shot: for me, adb did not find my phone either, i had to add its ID manually first – so maybe this is the same issue for fastboot?

To add the ID (see here for my original post):
find the ID via the “lsusb” command:

  • connect the phone
  • it might be necessary to put the phone into one of the two USB-modes “Transfer files” or “Transfer photos (PTP)” – I don’t remember
  • run lsusb from the linux terminal
  • disconnect the phone and run lsusb again –> you see which ID is missing, that was the phone :wink:


  • add “0x” + the first 4 characters of the ID (before the colon, so, e.g. “0x1234”) and add this string (w/o the quotation marks) to the file ~/.android/adb_usb.ini (create it if it does not exist)

but, again, this might not be it :confused: – good luck! :wink:

ah, i overlooked this before:

This also recently happened to me. After disconnecting usb, switching usb debugging and root off and then reconnecting usb, i could switch the mode and then enable root and usb debugging again. (and as mentioned above: make sure you have a data cable (u said you would, but better double-check ;))

That worked! Thanks! :clap::clap::clap:
Phone detected when started, drivers installed, etc. But not in fastboot mode (on a windows computer). Later or tomorrow I will try at home, on linux.

1 Like

Solved!! Thanks a lot! The problem was that USB mode was always charging. After Jme post I could switch to Fairphone os


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.