Which package is responsible for sending SMS messages?

No such basic questions, please, as per the post above yours :wink: .
We are obviously clairvoyant enough to know everything that has been tried already without it being mentioned, and nobody else will ever have this problem, find this topic and might be thankful for any idea.

2 Likes

I actually don’t since I uninstalled the GApps before I even connected the phone to WiFi or put my SIM card in

2 Likes

Hopefully you didn’t find the first bug of FP4 :grimacing:

It seems you are the only FP4 owner in the forum so far. Perhaps you can tell us a little bit about your first impressions of the phone and the things that do work :smiley:?

2 Likes

Tippe auf SmsManager | Android Developers

Well, this package wasn’t installed on my FP4 in the first place…

You may like to compare your list with this from

Google:

pm uninstall --user 0 com.google.android.apps.docs
pm uninstall --user 0 com.google.android.apps.photos
pm uninstall --user 0 com.google.android.videos
pm uninstall --user 0 com.google.android.apps.youtube.music
pm uninstall --user 0 com.android.chrome
pm uninstall --user 0 com.google.android.apps.turbo
pm uninstall --user 0 com.google.android.as
pm uninstall --user 0 com.google.android.gm
pm uninstall --user 0 com.google.android.googlequicksearchbox
pm uninstall --user 0 com.google.android.partnersetup
pm uninstall --user 0 com.google.ar.core
pm uninstall --user 0 com.android.vending
pm uninstall --user 0 com.google.android.gms
pm uninstall --user 0 com.google.android.gsf
pm uninstall --user 0 com.google.android.tts
pm uninstall --user 0 com.google.android.gms.location.history
pm uninstall --user 0 com.google.android.apps.maps
pm uninstall --user 0 com.google.android.feedback
pm uninstall --user 0 com.android.hotwordenrollment.okgoogle
pm uninstall --user 0 com.android.hotwordenrollment.xgoogle
pm uninstall --user 0 com.google.android.youtube
pm uninstall --user 0 com.google.android.apps.tachyon
pm uninstall --user 0 com.google.audio.hearing.visualization.accessibility.scribe
pm uninstall --user 0 com.google.android.projection.gearhead
pm uninstall --user 0 com.google.android.apps.restore
pm uninstall --user 0 com.google.android.configupdater
pm uninstall --user 0 com.google.android.syncadapters.contacts
pm uninstall --user 0 com.google.android.syncadapters.calendar
pm uninstall --user 0 com.google.android.onetimeinitializer

Then my guess was wrong (I am not a developer myself).

but the part with sms happened to me also, when I manually activated volte on stock. Try deactivating volte to see if sms works after that.

Who’d have thought this would be such a task. I’m giving up for now, good luck :slight_smile:

1 Like

Thank you very much for all your suggestions, but I’m afraid I can’t try them out at the moment. Yesterday I also removed com.google.android.ext.services, com.google.android.ext.shared, com.qualcomm.location and com.qualcomm.qti.optinoverlay (they were all mentioned to be safe for the FP3, that’s why I tried it) and now my phone doesn’t boot anymore, but stays in the booting animation forever.

That in itself wouldn’t be a problem, but unfortunately, using pm install-existing while being in the boot loop now returns cmd: Can't find service: package. After a bit of duckduckgo-ing I found out that this is because the package manager service is disabled and that you can enable a service by running am start -a. This however also returns cmd: Can't find service: activity, and now I don’t know how to proceed without needing to wipe the phone.

I know it’s more than a little annoying but you are making me laugh.

2 Likes

I’m happy that at least one person can laugh about it :see_no_evil:

2 Likes

+1

… and I’m really jealous. The first person in the forum who owns a FP4 and he bricks it :scream:

2 Likes

Seems it’s not yet bricked, though, as it can still be wiped :wink: .
Still not a comfortable position without a method to reinstall the OS currently.

3 Likes

Hi

How did you uninstall, can you reinstall rather than do a factory reset?
. BUT most of the articles if not all of them ( couldn’t find any article saying otherwise ) say that after using the command " adb shell pm uninstall -k --user 0 " to uninstall an app, you have to factory reset your phone to get these packages back which Is NOT TRUE.

First method :-

you can simply use "adb shell cmd package install-existing " in ADB and you’ll get the package back .

Examples:-
adb shell pm uninstall -k --user 0 com.android.something
adb shell cmd package install-existing com.android.something

Clearly I haven’t given up on you yet. :slight_smile:

or maybe

If you’re using pm uninstall rather than pm uninstall -k --user 0 com.package.name, I’m asuming that you have root access. If that’s the case, then its better/safer to use pm disable because you could enable them anytime with pm enable. If you’re talking about some “non-necessary” apps, but not a system component, then yes you can uninstall them. But be careful doing that. Do your research on the app before uninstalling them, because it could lead you into boot loop. Make sure to keep backups of your apps if possible, if something goes wrong, you could copy them back again to their directories. If you have root privilege, then yes, copying the apps back to their original place will retain their functionality. But if you try installing them without root, just as a user or using adb install, the apps will no longer be a system app, and most probably will be useless since they are already in the system, just disabled/uninstalled for the current user. A factory reset will reset all the apps like before. Hope this helps
How do I restore previously removed android system app with adb? - Stack Overflow

1 Like

Ok, so I made some progress. It seems to be a combination of com.google.android.gsf, com.google.android.gms and com.google.android.ims, but I haven’t worked it out exactly just yet.

Edit: I think I got it now: The responsible package is ims, but if you uninstalled the other two, you need to reinstall them, then send an SMS and then uninstall them again, otherwise it doesn’t work (I guess ims has to do some stuff that relies on the other two). The package does not need internet access to work however.

2 Likes

I have found this it provides a list of requirements for com.google.android.ims to function

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.