Whatsapp Updates on FP 2 Open OS

Thanks for your replies @urs_lesse Urs and @robbert.f :grinning:

@robbert.f why are you suggesting the Aurora store?
What about the Yalp Store?

Yalp never really worked for me; it tended to have issues with logging in and the search function barely ever worked. Your results may vary, of course.

I use Aurora store as my Play Store client and Aurora Droid as my F-Droid client, and the fact that the two apps have the same interface is also helpful.


It seems to be discontinued. I cannot find any apps here on my FP1 (Android Kitkat 4.4.4) and there are no updates available on F-Droid. It’s a pity that Aurora is not supported on Android versions below 5.

Well, Android KitKat is no longer supported since mid 2014. It is probably vulnerable to a myriad of vulnerabilities, including Spectre, Stagefright, …

That is what you get when you buy a device with MTK chipset (tho it might have improved?).

Aurora started out as a Yalp version with material design (which, IMO, looks far better [peaceful, serene] than the earlier [bombastic, chaotic] design).

Aurora Store got redesigned recently. Aurora Droid also took off, having the same design as Aurora Store. Which means there is less learning curve, and easier to work with.

I don’t have time to check my facts, but I remembered having read somewhere that:

  1. Yalp can still update the apps on your phone
  2. you can find the apps with the package name (com.xxxxx.xxxx)
    I will try to find the reference later.

Here’s a link with more info:

1 Like

I suppose you’re aware that the anonymous login function is currently not working so I assume it’s also not working for you when using a Google play account in yalp?


Ok, I understand. Guess I’ll have to try myself, thanks!

Hey @urs_lesse, how’s your experience been with Whatsapp on the Anroid emulation?

I’m asking because of this piece of text found on Whastsapp’s FAQ:

“Custom ROMs and rooted phones aren’t supported by WhatsApp. There are too many variations in these customizations for us to maintain a working product. Furthermore, custom ROMs and rooting don’t allow the WhatsApp security model to function as intended. If you’re using a custom ROM or rooted phone, other apps may be able to read your messages despite the end-to end-encryption.

I guess the same situation will apply to the Android emulation.
So my question is: Is it working properly for you?

I’m wondering why in that case their security model wouldn’t work too…anyone got an idea?

I cannot say whether encryption works in WhatsApp on my Android emulation. I hardly ever get any messages in WhatsApp at all, so I can contribute very little experience. I can say though that it does work (WhatsApp, that is) and that I was just able to update it (manually, as discussed earlier) to 2.19.329.

That’s already something helpful :slight_smile:


I didn’t try with a real Google account. Does Aurora have the same issue with anonymous logins?

1 Like

Yes, same for aurora. I’m not too optimistic that this will/can be fixed soon…

Thats a pity…
So the only way to get that kind of appnow is by using an apk, right?

I can at least confirm that Aurora Store works when using a Google account, so that’s one way of keeping the app up to date. AFAIK the anonymous login (which means using spoof accounts set up by the devs) was always against Google’s TOS so it was a matter of time before they blocked it.

1 Like

Doesn’t using Aurora or Yalp violate the Play Store Terms of Service anyway, regardless of logging in with a Google account or not?


Looks like you’re right:

3.3 You agree not to access (or attempt to access) Google Play by any means other than through the interface that is provided by Google, unless you have been specifically allowed to do so in a separate agreement with Google. You specifically agree not to access (or attempt to access) Google Play through any automated means (including use of scripts, crawlers, or similar technologies) and shall ensure that you comply with the instructions set out in any robots.txt file present on the Google Play website.

1 Like

I don’t know if Yalp it is discontinued, but moreoften it does not log in anonymously. The same with Aurora - perhaps gougle is more aware of it?

At this very moment I opened a new gougle account, with a complete other name and logged in with aurora. This works - and hopefully gougle is not going surfing my FP2.

Because we all know, we need the one or the other official app… sigh

1 Like

P.S. Even the APK Downloader of apps.evozi.com is moreoften than earlier not able to download the app from gougle play store. It’s going to be hard in the future to avoid gougle. This is may-be the reason why Fairphone seems to be rather reluctant to implement Open OS in FP3…

I’m sure this is unrelated. I assume it’s more a matter of available resources, cost and size of target group.