Whatsapp and Signal call have delay

Ever since I got my FP3 phone last November I discovered an issue where when I used Whatsapp, all my calls had issues with an audio delay from 2-5 seconds, that makes it almost impossible to speak to people.

I tried using Signal as well, it is a bit better but sometimes has delays as well. Not everybody is willing to use that app though.

I tried to call people from different phones using the same phone network and wifi, (Samsung Galaxies, iPhones) but no other phone would have the same issue, calling the same people. So it clear that my phone is the issue.

Making direct phone calls does not have this problem.

But I have not found anybody else having similar problems. Does anybody recognise this issue on their FP3?

1 Like

Idk if it’s going to change anything, but did you try uninstalling and reinstalling WhatsApp and Signal?

@Alex.A Yes, I’ve tried this, it did not make any difference from what I can tell.

1 Like

Maybe a factory reset? I never had that problem in my FP3, and I did a lot of Whatsapp video calls some months ago. If this doesn’t work maybe is something related to your own concrete device :sweat_smile:

Direct phone calls use a network which is optimized for voice traffic. Messaging apps send their packets over the general internet, which does not prioritize voice traffic. And hence the delays, I suppose.

1 Like

I can attest to the fact that VPNs sometimes do funny things with the connections. Sometimes a node will suddenly have an astronomical ping, and the whole data stream just sits around.

On another note, video calling consistently eats the hell out of my battery, so much that it often can just maintain a 2-3% range between charging and overheat pauses. It seems that it’s the charging circuit overheating, not the battery itself.

@ teezeh, Yes, I’m aware of the difference between network phone calls and internet calls. I’m only referring to internet calls using Whatsapp, where I tested different phone using the same internet connection that I had an issue with on my phone, making the same phone calls to the same numbers, none had the same problem. We are talking about fiberoptics connections, 4G connections, 3G connections, DSL connections, and even in two very different countries. So it’s clearly an issue with my device.

@ Mixigodo I think I did try that first time I got the phone and made no difference, maybe I will try again when I can afford the time to reset it.

1 Like

Hey @einsiol,

  • Have set the Data Saver setting for calls in WhatsApp / Signal / and so on to ACTIVE?
  • Have you set up a data tariff in Android 9 in the general mobile data settings? Maybe that data tariff overwrites settings and saves data for you. :slight_smile:


@JuengerJesu Low data use is not active on either Whatsapp or Signal. The system data saver is not active either.

I’ve experienced issues with internet calling on my device as well. In my case, it registers as a drop in connection, which returns after a few seconds. This has happened without fail in every internet call (Facebook, Whatsapp) I have made on my phone, which lasted for longer than a few minutes, over WiFi. I have experienced no issues with calls from my computer. I tried following advice on changing my router settings as in My FP3 doesn't like higher 5Ghz Wifi channels, especially channel 116. An internet test for latency provided better results for me when I changed my router to channel 52.

Although it feels like there has been some improvement on this, I still experience out of sync audio. I’ve now been connected through many networks, from very fast to very slow and the issues seems to have little to do with the connection quality.

I get the feeling that apps that encrypt the audio connection are having issues on my phone, if nobody else is experiencing this then perhaps it is just my device.

1 Like

Not quite the same problem but a few days ago I had an echo that was some seconds delayed that was so loud it made the call very difficult. EE UK using wifi ??

Hi einsiol, I am experiencing your same problems (up to 2-3 seconds delay) since I bought my FP3 last year. I looked around for other people reporting this issue, you are the first I find. I also add that often the people I am in a call with report echo when I am using the loudspeaker.

There is a topic about this: Echo in VOIP calls - FP3.



Since my post of 22 Feb Fairphone have recognised a problem with the microphone operations in handsfree/Whattsapp type use. This means there is no noise cancelling function and the echos may be somehow related, though I’m not at all clear how they could be.

On the delay side of the problem I’ve only had that in conjunction with the echo, where the echo was louder than the call, making it appear there was delay, but never a delay of more than a second.

Delays I imagine are more to do with the network structure having to reroute signals sometimes. and of course as previously pointed out having to encrypt and decrypt doesn’t help.

On the issue: