Whatsapp and local backup in Shelter

Hi guys,

have any of you tried installing WhatsApp in Shelter trying to restore a local backup without root privileges?

  • WhatsApp doesn’t seem to recognize the local backup. It looks like WhatsApp either does not have the appropriate rights or is looking in the wrong place. I have stored the local backup in the working profile here: …/Android/media/com.whatsapp (Android 11)
    In the normal profile, however, it works without problems.
  • adb backup/restore does not work in the working profile. At least you (maybe just me) can’t run the restore under the working user (user 10).
  • Seedvault does not work in the work profile unfortunately.

I have run out of ideas. Do you have any more?

Greetings
Knefl

1 Like

While I have no particular insights into Shelter, I had about the same problem when migrating to a new phone. The problem is that nobody at WhatsApp seems to test the local restore as everybody is expected to use the Cloud backup.
In my case what worked was:

  • make sure WhatsApp is totally clean on the device you want to restore the backup on (delete data and cache)
  • then manually give it storage permissions (“Files and Media”) - it will not ask on first run then then fail to detect your backup file otherwise
  • in my case the correct place for the database backup was /Android/media/com.whatsapp/WhatsApp/Databases
  • only then start WhatsApp for the first time and it should hopefully detect your backup in the first-run process
2 Likes

In order to copy files from personal to work profile to have to activate File Shuttle in Shelter

Hi mde,

thank you for your answer.
I was able to restore the local backup in the Personal profile (non-Shelter/non-Work profile) before I tried using shelter. The phone was absolutely “fresh” - directly after a factory reset. Then I did another factory reset, installed shelter, copied the local backup into the work profile using Shelter’s File Shuttle and installed WhatsApp via apk in the Shelter/Work Profile.
But WhatsApp did not prompt me to restore a local backup like it did in my Personal profile. However, in both cases I put the local backup under /Android/media/com.whatsapp/WhatsApp/Databases.
Are you sure about the path Android/media/com.whatsapp/Databases?

Greetings
knefl

Curious : Which phone and OS are you using?

That path on my FP3 A10 0134 doesn’t have the /Databases folder, but then I don’t backup any WhatsApp

Hi @AlphaElwedritsch,

thanks for the hint, but I already knew about the File Shuttle. This way I was able to copy the local backup to the working profile.
Do you perhaps know if the data has the correct permissions after the File Shuttle copy operation. Or with which tool you can easily see that? I rather have the feeling that WhatsApp does not find the folder. Either a permission problem or WhatsApp is looking in the wrong place due to the work profile partition.
Either way, I currently have no real idea why it won’t work.

Greetings,
knefl

Hi @amoun,

I tried it on three different phones. A FP3 with /e/OS (A10), a FP4 with /e/OS (A11) and an old Oneplus 5T with LOS 17.1. I couldn’t get it to work on any of the three devices in the work/shelter profile.

Greetings,
knefl

So not on a ‘vanilla’ Android? Could it be that? Maybe someone with the experience of both can enlighten?

If it is an OS issue then I would change the title :slight_smile:
All the best

Sorry no experience in that. Do not backup my WhatsApp. Never
If I loose it, then i loose it
I don’t have any data in there that is worth backing up. Only petty talk and cat videos :rofl:

2 Likes

You are right, I missed one directory level there, /Android/media/com.whatsapp/WhatsApp/Databases would be the correct path in my case. I believe to have read somewhere that there might be differences between the Android versions as well regarding how difficult the restore is. In my case it was the stock FP4 Android.
I’ll correct my initial post…

Idea

What happens if you install WA in shelter and do a manual backup.
Then you should be able to find the backup in the shelter filemanager and can figure out what the correct path is.
Then delete this backup and replace it with yours.

Maybe this works. Well, It’s worth a try, I mean…

1 Like

reg the path: when you connect the FP to a PC can you see a separate WA folder created in the system outside of Android? I recently (no within shelter) restored a local back up and it did not work when putting it under Android/media… but WA created its own folder directly into the internal storage and when I put the file there, back-up was found and restored.

1 Like

Good news: It works now. The local backup was restored without any problems after I discovered the issue.

So what did I do:

  1. As before, I copied the entire WhatsApp folder from my PC to my personal profile internal storage (you can’t see the work profile directories from the PC).
  2. Then I copied the whole WhatsApp folder to the working profile via File Shuttle to /Android/media/com.whatsapp/.
  3. And here the problem occurred:
    For whatever reason Shelter/File Shuttle renames all files unknown to it: The file extension .bin is then appended. And WhatsApp then no longer recognizes it.
    I had only checked the number and size of the files - but not that the file extensions could change.
  4. So, I removed the .bin file extension everywhere.
  5. Then I installed WhatsApp and the restore worked right away.

I would like to thank you all because your questions and suggestions made me do the whole procedure again (for the hundredth time) and this time take a much closer look.
Maybe it will help others with the same problem.

Greetings,
knefl

8 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.