What is the way for signature spoofing with OS OPEN Android 9 in 2021

Hi !
I am on open and I updated today to Android 9.
It looks OK but microG says no signature spoofing.

My old way was the Xposed framework install from TWPR. This looks now out of date.
Is MAGISK now the “new hot shit” ?
And how should it work? I am in circle of confusion.
I take the fdroid version and if want in it install “magisk” I have do chose a
“boot.img” (why or where to get?)
I chose keep “AVB 2.0/dm verify”. The I get error “unable to extract files. Installation failed”.

The website of magisk looks very helpful but I don`t get it.
I need “Riru” but where to chose or search in Magisk?
There are little files on github. But what to do ? Where with which file?
After 2h I am official confused…
The most topics here for these problems are looking old for me. So I don´t find a solution.
Thanks a lot !

After lunch and with new power I get it:
Uninstall MAGISK
Install version from https://magiskroot.net (NOT Fdroid !)
Install within the app MAGISK with option keep “AVB 2.0/dm verify”.
This time no error. Restart.
Start App Magisk.
Now in the bottom is a little flying 4 piece menu. THIS is the MAIN menue !
The 4th point is Moduls and there you can chose similar to xposed you needs.
For me I installed: Riru + ( Riru-EdXposed ?) + Riru-LSPosed.
Now is there a new app LSPosed. There a modules again.
An there is FakeGapps !
Actived and Restart.
After 2 Attemps and uninstall of old Xposed is mircoG showing all OK in self test and
Signal and Threema are working again with google-PUSH-service.
I am not sure that I know what I did, but it looks OK now.
Good luck to others with that “simple” stuff !


I understand that I need to turn on signature spoofing again, after upgrade to Fairphone Open 21, as microG shows many options unchecked.

The instructions here How to Install Magisk App v22.1 [Full Guide] | MagiskRoot say to upload boot.img to the FP2 - where do I get this from? The XDA-developers website did not show an easily recognizable hit when I searched for “FP2 boot.img”.

Danke & Grüße von nobi

I installed Android 9 manually (see this site). I found the boot.img in the zip downloaded to install Android 9.
I guess you can do the same if you download the OTA zip from the same website. Unzipp it and you will find the boot.img.

In my opinion you don´t need this to do for FP open because its for rooting.
If you read the whole site of Magisk you will found out that one of the main goods is rooting.
FP open is already root by delivery. So you don´t have to do that.
I took the option “keep “AVB 2.0/dm verify”. A fast install and then restart.
For me its worked without boot.img

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Before I start: yes, I have seen the other topic on this issue. Thanks to the bot automatically closing “old” topics (why?! I never understood why some forums and bug trackers insist on doing that), I have to make a new topic.

I'm currently using the microG fork of LineageOS on my FP2 since that seemed to be the easiest and pain-free way of running microG. I do prefer FP Open over LineageOS for a few reasons, mostly unrelated to my question.

Before I moved over to LOS+uG, I did manage to painstakingly get signature spoofing working on FP Open using Magisk; it was clunky, required patching one of the RO system images (boot.img?), replaced the system-provided su with its own and required the installing 2 or 3 Magisk modules to actually work. A house of cards that I’m fairly sure would collapse with the next update, if updating in this state was even possible.

The question is not “how do I install microG on FP Open”, but rather “is there a better way to do so than what I’ve done”? I’ve seen that people used to patch their ROMs before they were “odexed” (whatever that means). Now that’s no longer an option, is Magisk/Xposed really the only way? Is there a way to update my system with them installed and/or have them not install their own su implementation?

Just asking to open could help😉

Making it clear that something like that is even an option could also help :wink: I’m just used to the old BB forums; when you create a new topic with a question:

Closed duplicate thread, use the search function.

And when you ask in an old thread the mod was referring to:

Thread locked, do not necropost.


But yes, thank you.

I don’t know another way. But for me is on FP2 open Magisk THE simply way!
The app is still there after a OS update. New Install “in” the app, Restart. Ready.
Last 2 or 3 OS update like this without any problems.
Updates from Magisk itself like the same way. (confirm in the app, Restart. Ready)

So a better way could be very difficult to find … But good luck!

1 Like

The app is still there, yes. You say ‘new install in the app’, means you’re patching the boot.img again, but at least you don’t have to re-install all the modules.

What about Magisk’s “root” functionality? Is there a way to not have that installed and use the provided root (enabled in the Settings app, System, Developer options)? I tried having that enabled with Magisk installed and I got an error message when opening the Magisk app complaining about it.

You say ‘new install in the app’, means you’re patching the boot.img again, but at least you don’t have to re-install all the modules.
What about Magisk’s “root” functionality?
Yes I get a message too. But I know no problems belongs to root. So I didn’t care…

1 Like

So it looks like the freshly-released Android 10-based FP Open doesn’t work with Magisk… :slightly_frowning_face:

When trying to install Magisk in the Magisk manager app I can’t choose ‘Preserve AVB 2.0/dm-verity’ like on Android 9, the only option shown to me is ‘Patch vbmeta in boot image’, which according to the installation instructions should be ticked in the case of FP Open; the ‘Direct Install (Recommended)’ method fails with ‘Unable to detect target image’ and patching manually with the ‘Select and Patch a File’ method gives me an unbootable image, i.e. flashing the image I get from this by rebooting to bootloader and running fastboot flash boot magisk_patched-24200_VwYxZ.img results in getting stuck on the bootsplash ‘Fairphone Powered by Android’ screen.

Did you try out the new A10 FP Open @Olli_GT? Did you manage to get Magisk working there?

I tried again the next day, this time with (moderate) success:

  • Uninstalled Magisk 24.2, downloaded and installed the previous version (24.0) and updated to stable (24.1, a few hours later 24.3 was released) from within the app
  • Now the direct install worked, still no option for preserving dm-verity but the vbmeta option was already pre-checked so I left that on
  • DO NOT install Riru unless you’re sure you need it, see below, instead go to settings in the Magisk manager app and enable ‘Zygisk (Beta)’
  • The Magisk module repo in the app has been disabled so all modules have to be downloaded from their respective websites; download and install the LSPosed Magisk module, choose between the Riru and Zygisk release depending on whether you installed the former or enabled the latter
  • FakeGApps isn’t in the list of modules in LSPosed so install it from F-Droid, activate and set up the module in LSPosed, now signature spoofing works

A note from a layman on Riru and Zygisk: from what I understood, Zygisk is a new effort from the Magisk developers to provide the same functionality that Riru does without needing a separate module. As such, the development of Riru ceased, its GitHub repo is now read-only, and all Riru modules are advised to switch over to Zygisk. LSPosed has switched over to Zygisk and the existing FakeGApps module works with it, so unless you’re using Riru modules that don’t have a Zygisk version then there’s no reason to use Riru anymore.

What I could not get working was SafetyNet device attestation, even with the Universal SafetyNet Fix module: YASNAC reports both basic integrity check and CTS profile match fails, microG settings just says ‘Failed: Integrity check failed, ROM is not clean’. Ideas on how to get that working are appreciated.

1 Like

No, i don’t try V10 yet.
I always wait min. 10 days for minor versions and 4 weeks or more for major version.
Early adopter with fairphone is too often a nerd thing …

1 Like

I tried al lot now and I give up. Same experience like you (on Andr.V9+
10). No SafetyNet for me on FP2 open.

Sorry, I forgot these thread and made an new one for SafteyNet…

But you don’t miss anything (The German part is only a childish low level discussion about the safety of ‘root’ and the moods of developer)
Technically only the English contributions are filled with (hopeless) content

It’s odd because microG absolutely 100% works with SafetyNet; when done properly, that is.

I’m currently on the April 3, 2022 FP2 build (LOS 18.1, so Android 11) of microG’s LineageOS fork and I pass SafetyNet attestation out of the box, no changes required.

It might be helpful to reach out to the developers of microG, or at least to the maintainers of the LOS fork, and see what they’re doing to their images to have them pass SafetyNet attestation…

1 Like

I have less hope: The Fairphone developers will not do so much anymore for FP2. Only security or important stability patches I think.
And if LOS will work, this would be the alternative.