Weird wlan connection with Telekom speed port smart 3

Hallo,

I got the fairphone3+ last week and cannot connect to the home wlan (I have a telekom speedport smart 3). Or better, it shows that it is connected, but it is not. I downloaded tha lst speedport 3 firmware, but it doesn’t solve the problem. Any ideas?
Thanks
Matteo

Welcome to the Fairphone community.

How is the WiFi configured? Did you try 2,4GHz or 5GHz or both? Which security settings? How do you tell, that the FP3 is not connected?

The router provide at the same time 2.4 anf 5 GHz, security is WPA 2. So, it’s not connected because when I try to get to a webpage, it says that I’m offline. It doesn’t even send WhatsApp messages. However, the phone shows that I am connected.

The router might provide both frequencies, but which one do you choose?

Is the FP3 doing MAC randomization?
If yes, is the speedport able to handle it?

In order to “choose”, you @matteo_lattuada will have to fix the the frequency band in the WiFi settings menu:

I don’t think it does

Just guessing: on which channel is your Speedport operating?

Referring to the previous post.

I have set my FP3phone to use 5GHz only and whereas the router transmits on both 2.4 and 5 I have set each with a different SSID, [Fritzbox5] and [Fritzbox 2_4] for example, both use the same password an dWPA2

However even without being specific you should be able to connect.

Can you access the router via a browser? 192.168 etc.?
Are other devices connecting?
Can you see the FP3 in the router info ?

If so, the parameter is in Settings > Network and Internet > Wi-Fi > Network details > Advanced > Privacy.

Not necessarily, as amoun pointed out, when you give the two frequencies different names, you can choose without changing something on the device, you want to connect.

I read into the “same time” phrase a meaning of “same name” - apparently that is not as clear and might not be true at all. If not done already, splitting up the frequency by name will ease debugging for sure :+1:

As far as I know this “5 GHz higher channels” thing only concerns certain routers, I can only remember the Fritzbox for sure. My FP3 is perfectly happy on channel 124 picked by the router using DFS. More info here.

In your reference you claim of having problems on channel 112 yourself, don’t you?

If Android shows that it is connected to the WiFi (I’m assuming a “standard” Android here), that means that it can connect to the Google check URL that exists for this purpose. So I’d assume that it is indeed connected to the WiFi properly for a start.

From there I see various possible reasons, but none that are connected to the frequency:

  • The router has some sort of child safety feature or similar that restricts internet access by default in your setup - do other (new) devices connected to the WiFi work or do they show problems as well? If there is such a feature, it is usually based on MAC address. So if you’re indeed using a random MAC as discussed above, that would be a problem, else it’s not really.
  • Some sort of DHCP or DNS issue. Can you check the network parameters once you’re connected to the WiFi? (WiFi Settings → Cog next to the network you’re connected to → Advanced → scroll down until you see “Network Details” - possibly post a screenshot here, black out the MAC if you wish.

Edit: Additional information that would be important for troubleshooting:

  • Does the phone work with mobile data?
  • Does the phone work on other WiFi networks?
  • Are there any firewall/internet filter apps installed or custom DNS settings configured?
  • Is this in fact a “standard” FP OS or a custom ROM?
1 Like

Hi @waldie, it seems to go better now, after choosing to connect to 5GHz

2 Likes

No, I can’t say that choosing channel 112 was a problem in itself, though it did not work at one point. I manually set the router to this channel having read in the forum “that one should avoid higher channels” (I paraphrase). But that didn’t help. I don’t think the choice of channel had anything to do with my problem.

The problem came from an obsolete WPA1/WPA2 AES/TKIP security setting. As soon as I set this to WPA2 authentication and AES encryption, the FP3 was happy to work on any channel chosen automatically by the router. As I write, it is connected on channel 124 at 433 Gbps, using 802.11ac.

2 Likes
  1. Yes
  2. Yes
  3. I don’t know, how can I identify it?

You mean it’s working :slight_smile:
:man_surfing:

Have you selected 5GHz only on the phone then ?

The router indicate that the 2.4 GHz and 5GHz are active. Now, for the FP, I chose the 5GHz and it seems to connect well.

1 Like

@amoun , yes, I just selected one of the two GHz options on the phone.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.