Weird behaviour, FP2

I must say I am getting very frustrated with my FP2. I got it in Feb 2019 so it´s a little over a year old. From the very beginning I´ve had issues with this particular one. Here are a few examples:

  1. I have not been able to connect it to any computer in order to move photos and videos from the phone to the computer. The computer just doesn´t recongnise the phone and I am not able to put the phone in a transfer mode. There just isn´t anything like that in my phone. I wrote about it here last fall and did not get any answers that would have helped. I tried with two different cables and neither works. Meanwhile the same cables work just fine with my work phone, which is also android os. My phone just doesn´t have the options that other phones have for example in the thread that I linked above.

  2. My phone keeps changing the wallpaper by itself to this default paper. Usually this is related to situations when my phone just freezes (at times in these situations it also reboots itself), which brings me to my next example.

  3. My phone is extreeeeeemly laggy. To give you an idea of how laggy…

  • I find it “hilarious” that when the phone is locked and I try to open the camera, it seems that the camera opens but then to really get to the point that you can press the shutter, the screen lock goes back on. So it takes so much time that the phone thinks I am not using it and auto locks itself again.
  • My camera roll is full of photos of my pocket or blurred photos because often times (when I actually manage open the camera) I press the shutter but nothing happens. I think the camera just doesn´t work an put the phone back to my pocket and when doing so, the camera fires. On time I counted an it took 9 seconds from pressing the shutter to actually take the photo. And that was in a daylight and I had already focused the camera. This has got to a point that I just don´t use the camera anymore because it is practically unusable.
  • I´ve missed calls (alot) because a) I hear that the phone is ringing but nothing happens on my screen. It´s just black. or b) The phone rings, I see who´s calling but when I try to answer, nothing happens. The screen is unresponsive and the phone keeps ringing.
  • All the apps are veeery unresponsive, laggy and slow. We are talking like “it takes at least 10 seconds to open an app or a message for example” -slow.
  • GPS locating on a map is very slow also. So much that I can´t use this phone for navigating, because it´s very likely that I miss the street because my phone thinks so long.
  • I have big issues with the Bluetooth. For example my Garmin watch. The phone says it´s connected, but it actually is not. This happens every single time I try to sync the two and I have to forget the device and re-pair it.

So far I´ve rebooted the phone many times, I´ve reset to factory settings, I´ve tried different modes. I get that if the phone gets full of photos and other data, it might slow down but I´ve had no problem with my work phone which is also Android but Samsung, and has also at times been full.

I am also perfectly aware that when I bought this phone I bought it because of ethics and was aware that I don´t get the fastest processor on the market. I thought it´s the price you pay for a fairer world. However, I did not think that I get a phone that is so slow that lot of the time many of it´s functions are practically unusable. And I might add this weird and laggy behaviour is not something that happens every now and then but all the time. I might say its more likely to be laggy than work even decently.

In Finland we have a saying that something is “a monday piece”, which means that in general the product is good but you just got a “bad apple”. I hope mine is like that and other FP2s work better.

I also wish to know is there anything like a return or change policy?, if mine is a bad apple. As I said I´ve had problems from the day one. At first I thought this was something all Androids have (I had always had iOs phones), then when last fall I finally admitted this is not working the way it should, I´ve tried everything to get it work properly.

Do other FP users have had similar issues? I really love the idea behind FP and really hope this would work so is FP3 any better or do I just have to admit to myself that this is not the way for me to work for a better world and go back to iOs?

This is not normal.

If a factory didn’t fix it you can go one step further to exclude the OS gone bad as a reason.

If you have the official Facebook App installed, you could uninstall it to see whether it has gone rogue (which it might do).

You could try whether the issue persists if you remove your SIM card(s) from the phone. Especially SIM cards getting old sometimes cause trouble which you wouldn’t attribute to them logically.

If you incorporated an SD card into Internal Storage instead of keeping it as external storage … don’t do that, it’s inviting trouble. SD cards are pretty flimsy and when (rather than if) they go corrupt, they will hamper phone operation or corrupt the whole Internal Storage.

In the end this needs fixing. If nothing here in the forum helps, you should contact Fairphone support …

Thanks for your help, @AnotherElk

No, I haven´t had the FB app in this phone ever. I do have WhatsApp and Instagram which as we know are owned by FB, though.

Don´t think this is the case as I got this SIM card the same day I got this phone, in Feb 2019.

Haven´t had an SD card in the phone ever.

You got that right, friend. This has been very frustrating. I am considering Lineage OS as well but what would that mean? Is it any help, I don´t know.

Thanks, I´ll try this next.

Can’t hurt to try without it nonetheless, then you’ll know for sure.

If you are not shying away from trying things before going through the support motions (which could mean sending your phone in for diagnosis) … sure, why not try LineageOS?

LineageOS doesn’t have Google Apps and services by default, so if you need those, you would have to additionally install Open GApps.

Furthermore LineageOS isn’t a Google certified Android like Fairphone OS is, so to play it safe with your Google account, you would then want to have a look at Google’s device registration for the use of Google Apps and services on non-certified Android OSes …

Ok, I am trying it now.
BTW I noticed another odd thing. In phone´s settings I see that backup to Google is on. However, when I go to my Google account, there is nothing that indicates that it actually backs up. I mean, shouldn´t there be a file of folder in my Google Drive?

I don’t know, I’m not using Google Drive (and most other Google Apps and services, for that matter). Here’s a guide …

Nope, not helping. When trying to open the phone after a restart the screen actually gets locked again before it lets me to type the lock code.

Backups are not shown in the overview. Here’s how to mobile backups in google drive on a computer via the web version (or phone, if you switch the widget towards the top of the page)

Aaa! Thanks. Nevertheless, there is nothing there. Weird.

This is weird, indeed.

I just remembered … When I was playing around with operating the phone without the display (a long time ago) I noticed severe lag in everything.

So, moving into hardware territory … Perhaps there’s contact trouble somewhere? Disassembling the phone, carefully cleaning the contacts with cleaning alcohol and reassembling the phone again might help with that. Here’s a nice video (without the cleaning, though) …

Is there a button or any way to force backup the phone? I have backup set up in the phone but the backup folder in Google Drive is empty. I just backed up WhatsApp in that same folder and that jumped there just as it should. But nothing that indicates that the phone itself has backed up.

Thanks. I suppose I have to try that next then. I just want to try that first idea of yours first, but try to get the backup to work first. This doesn´t seem to back things up to google drive.

Take this video for example. Are the settings phone related or what ´cause mine doesn´t have that kind of a view. I don´t have a “Backup now” button in mine.

In case this doesn’t work out, here’s a different way …

It’s good, what you’ve all tested already! And It’d be great if you could find the root cause for all your problems and solve it.
On the other side - considering all the problems you have I agree it doesn’t sound normal. So I’d recommend to #contactsupport . They can tell you if you might change the phone. But sure - even is this case - a working backup would be helpful…

Thanks a lot for the both of you but I decided to get in touch with the support. I read that through and felt very uncomfortable doing that. Mainly because I don´t think I am tech savy enough but also beacause I don´t feel I should need to do things like that to be able to use my phone.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.