Website bug report: register and login issues

Hi all,

I just want to duplicate here a support request (not really as it’s kind of a bug report) that I’ve already sent via the contact form to the official Fairphone team. I do this as other members of the community could potentially confirm this as a common mis-behaviour of the website interface and make use of my workaround or tell if it’s just a sporadic/unique-to-me error.

I’m reporting this as I’ve noticed 2 issues in trying first to register then to login from the main webpage interface header at “https://www.fairphone.com/en/” , namely by clicking the user icon on the top right corner, which makes a little contextual menu appear and into it:

  1. clicking on the “New customer? register here” text lands to the webpage “https://shop.fairphone.com/es/web/signup” which is blank with the “500: Internal Server Error” message;
  2. clicking on the “Login” blue button lands to the webpage “https://shop.fairphone.com/es/customer/account/login/nl” which shows the custom 404 Error Page Not Found;
  • I’ve only found a workaround, and thus the possible culprit, for the 2° error: removing the “nl” appended to the link it correctly redirects to the “https://authentication.fairphone.com/u/login?state=<UNIQUE-ALPHANUMERIC-PARAMETERS>” thus letting the user proceed with regular login.

I would like to attach the screenshots of all of these behaviours step-by-step, which I did in the support form, but here it doesn’t seem possible to add images or files (and I don’t think it’s worth hosting on a 3rd-party site).

To the support team I’ve asked to please solve these issues as they’re very frustrating for new and returning users (such as me and the friend who referred me to Fairphone).
Hoping such a report will be of help I wish the best with this project and to all of the wonderful community supporting it out here! :seedling:

2 Likes

Just for the record. Do you get the same result when you use a different browser?

Please note that this is a user forum so with “your” you are not addressing Fairphone.

Else currently there are many (not to say too many…) issues with FPs new HP and yes its annoying that its still ongoing.

@anna_jopp is there still work in progress and when will the merge be finalised?

1 Like

It is possible. Maybe you’d have to read a little bit more around here to reach a higher “trust level” (see forumtrustlevels ) to be allowed to.

And I can confirm your error messages (at least for the URLs that you’ve mentioned). So here are the screenshots :slight_smile: :

1 Like

Personally, I didn’t try another yet as I’ll do it for science asap, but the friend referring me for sure was using a different browser (and OS if that matters) than mine>namely LibreWolf (on MXLinux)

Thank you for letting me notice the wrong use of “your”: I know this forum status and, as written in the post, I was duplicating the report from the contact form to the official support -thus the wrong use of the possessive pronoun ;D

1 Like

Many people think this here is official contact with FP, so therefore we mention this always when we see it.

2 Likes

Hi @mate1, thank you for flagging this. I just talked to my colleagues and they say they are already aware of this bug and working on fixing it :crossed_fingers:

7 Likes

Late reply, but I’m glad to see the login works now and thus my reporting was useful, thank you for taking the time to read here and talking to your colleagues! Cheers :seedling:

2 Likes