Warning: Latest /e/ update from Oct 3rd might break the phone

To everyone using /e/ on the FP3: I would wait with the very latest update from October 3rd. I installed it and the phone is now not starting anymore. See also the thread in their GitLab, lower end (copying the direct link doesn’t work for some reason, sorry). Seems there are more people who are facing this problem.

Oh, if anyone has a clue how to solve this issue (apart from factory reset), I am open for any hints :slight_smile:


Ah thanks Elky, exactly what I needed, forgot about the A/B thing. Will try that right away. :+1:t3:

Am I getting you right when I conclude that this problem can only affect users who installed TWRP and /e/OS on their FP3?

No, TWRP has nothing to do with it … it seems an /e/ update would just overwrite the changed boot partition including TWRP, if TWRP was installed.
So it doesn’t make much sense to install TWRP on the Fairphone 3 anyway. You just boot it with fastboot when needed.


Phew, you saved my day. Switching to the other slot worked like a charm. Thank you so much! :pray:t3: :ok_man:t3: :relieved:


I switched to the other slot and had to go through setting up /e/ for first use. Is this normal when I never booted from slot b before?
None of my data was there. I did not actively choose to do a factory reset. Any ideas?

1 Like

Lucky me!
I had no troubles with the latest update.

If you didn’t somehow choose to do a factory reset that would be a very serious issue.


You really mean the 3rd October build?
They retracted that because of the issue.


Got me! :blush:
The update says 30th September.
My bad. I just installed it yesterday and did not expect two updates within 3 days.

Lucky me, that I missed it. :wink:


Yeah, they wanted to react to the backlash against the unannounced status bar extravaganza included in that update and revert this change quickly to bring it back later with an opt-out switch.
Well … good intention, but it’s not good to rush updates obviously.


Did you do exactly the same steps as outlined in the solution? If not, what did you do different?

True, but still you have the messed up top bar without any notifications but with the operator constantly showing. :stuck_out_tongue_winking_eye:


I had the same problem with the October 3 update on the FP2. After installing it the phone displayed the boot animation for quite some time and then rebooted into TWRP. Had to reinstall the September 30 version to get it up an running again.

I have an ALARM problem on my FP3 since the latest update of beginning of October. the update has changed the main screen appearance and my alarms don’t work anymore!! I shuted down few times, but problem still there. anyone got a clue? thanks

Are you talking about /e/ or Androuid 10? For the latter, the issue has been solved already:


Perhaps here’s something to try … Alarm not working after Android update.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.