W-LAN fail to start after reboot but the Update to 1.8.7 was finished successfully with all reboots two day before

Hello Fairphone Forum Users,
first I would like to describe you what i did and when.
On Wednesday Evening last week (09/16/2015) I have Updated our fairphone to the last OS 1.8.7 (1.8.5 where installed before). All looks fine the first reboot and the second also, then i install the google apps how it was me shown and after the reboot no. 3. all looks fine again. On thursday i write my wife which is using the described fairphone some messages and I noticed that they not be delivered to her, so i send her a sms this would be delivered realtime and as she recieved the sms she opened the messaging apps to look what is wrong and now she becomes my not delivered messages from before. But later again where the messages only delivered when she opened the messaging app manually. Because it was on Friday the same, i did reboot the phone when we was booth at home in the afternoon, after i had looked what was wrong. And now comes the greatest Problem, the W-Lan will not starting anymore :sob: , when i want to start it manually, it didn´t work the Icon flasshing all the time “on off” and touch on it change nothing (see Attachement “01.jpg”) . When i will go to the setting --> W-LAN to activate it there, i cant activate it and it tells me that it seems to activate the W-Lan currently but does not happen (see Attachement “02.jpg”) . Please Help us we cant activate the W-Lan since yesterday, the Internet over mobile data transmission, from our phone provider runs but it is limited. Reboot the phone again will change nothing, when i have take the battery out of the phone for a short time, its also the same result.
I have read the last days many forum posts here and have searching in the web but there was no solution with my problem to find :frowning:
The solution with the wpa_supplucant.conf it does not work, i think that i don´t find the correct one.
Now the google Playstore will not run, too. When I will start it, it will closed immediately.

I would be grateful for a quick response and hope you have a solution for us.

This seems to be two problems:

This is familiar to what users are reporting here:
I’ve posted my own experiences in this thread as well. For me the steps I provided there fixed having to manually retrieve mail. Clearing the cache of google play services is a good chance to get back play store functionality as well.

Now the wifi completely not working is another thing. I can’t see the picture you referred to, but I’m assuming you’ve seen this post and the problem is similar (if not, what do you see?), as you mention:

So, which one did you find? It should be at the position mentioned on XDA (/data/misc/wifi/wpa_supplicant.conf), though you can only access this file as root or via apps that use root. Note that removing this file will wipe your saved wifi settings. Just out of interest, do you use F-droid? (If you’ve never heard of it, you probably don’t) - so far the only issues reported to be fixed by removing this file were caused by F-droid.

Hi Johannes,

thanks for the answer to my question,
Ok I will clearing the Playstore Cache today in the evening than i will post the result here.
To the W-LAN yes this solution i had seen, and i try it with the EFS Explorer who don´t find the file in "/data/misc/wifi/"
I find the file in “/system/etc/wifi”. I know that it is possible that this is not the correct file but there come the first problem again i can´t download another app because the playstore does not run :frowning: .
The manual update to 1.8.7 without delete my data i tried again but this changes nothing.
No I don´t have F-droid.
So i will first become the playstore running and then i try a app wich can delete or move the wpa_…conf and then I will write the result.

Thanks :smiley:

II had to install another app that uses GCM (like WhatsApp or Hangout) to get push working again.

Also, if you are able to browse website using the Wifi connection, there is no need to fiddle around with wpa_supplicant, cause obviously, you hava a internet connection. To test the Wifi, make sure you disable mobile data in the quick settings.

Good Luck!

Hi Ben,
thanks for the information about the GCM service I will whait until a Update for this Messangers are relesed, I hope this will correct this issue.
To your second information, i ll be shure it was the mobile data and not the wifi :wink:
But this is no more importent because i have solved the wifi an playstore problems but this i will write under this reply.

Hi Faiphone Forum,
i am happy that i can write that the problem are solved. I will write details how today in the afternoon or evening becaus i am out of time now.


Hi Fairphone Forum,
so i want to describe which way i must go that the phone will runs correctly again.

  1. downgrade to 1.8.5 manualy by using a sdcard (Manually install Fairphone OS software update)
  2. connect to the phone from a computer and using the adb shell (see below the adb describtion) to delete the /data/misc/wifi/wpa_supplicant.conf how it is described here in the forum Fairphone WLAN Key Backup
  3. reboot and after i can configure the wlan succesfully :smiley:
  4. configure that the display don`t go to standby until power is connected in the developer settings and deactivate sophos anti virus for the update
  5. connect the phone to the power supply and update again to 1.8.7
  6. install the google apps and configure they with my google account
    after this i am taking back the settings from no. 4 this it was :grin:
    All looks fine the user data is not deleted and the wifi and messaging apps runs correctly again!

Thanks a lot for your help and here are the links to the adb shell instructions :smile:
[Anleitung] ADB unter Windows einrichten
PleaseJava Development Kit (JDK) 7
Download Android Studio and SDK Tools | Android Developers