VoWIFI works... sometime

on my FP3 (non +), the VoWIFI options is enabled.
the carrier (SFR) has certified the FP3+ as VoWIFI compatible, as the FP3 share the same hardware for telephony (correct me if i’m wrong) it should work.

the problem is, it works… sometime.

when i’m at home in a area where i get SFR carrier signal, the vowifi is not active.
when i go to an area without signal, sometime, the vowifi will switch to active… .sometime not !
if i disable/enable again wifi , the vowifi sometime appear (only if i don’t have any GSM signal)
if i do it while having GSM signal, the vowifi is never enabled.

in my house, there are lot of area without any signal… so would like to get vowifi enabled and active as long as i’m connected to wifi, GSM signal or not !
that’s exactly how behave the pixel of my wife…

why does the FP3 is si capricious with the vowifi ?

There are some issues.

You can ensure that the phone doesn’t try switching between Network and Wi-Fi
You can set the phone to only use 5GHz as the 2.4Ghz can get interference from 4G and 5G networks as well as Bluetooth and any nearby cooking microwave, the latter two always use the 2.4Ghz sopectrum.

well that’s already the case: the wifi is set to 5Ghz

1 Like

It might sound stupid, but you might try

  1. enable airplane mode (and keep it!)
  2. reenable wifi
  3. check, vowifi symbol shows availability
  4. check call functionality in both directions functional

and then report back on the availability of VoWIFI.

Is your Wifi connection always on full bars or might there be interruptions on that end too?

Do you actually encounter decreased call quality or are those blocked when your phone doesn’t show the availability of VoWIFI? Just want to exclude it’s just a cosmetic problem :wink:


That’s not cosmetic. If the vowifi symbol is not here I cannot call or have lot of quality issues due to bad reception

So I made the test.
Currently the phone does not show vowifi symbol, while I’m connected to wifi and gsm

Now I put flight mode and enable again wifi. The vowifi appear and I can call.

Then I switch off wifi a d switch it back
The vowifi never appear again…

It seems that if I get a disconnection from wifi, the vowifi is not back when I’m connected again

I have good wifi reception in my house. But as only use 5ghz I have 3 différents AP (ubiquity). So the phone sometime disconnect and reconnect immediately on another ap
In this case, the vowifi is gone

If I lose gsm, the vowifi appear after about 30 seconds

The problem is:
a tiny disconnection from wifi mean no more vowifi until I lose gsm again. Because when wifi connect, if there is gsm signal, even poor, the vowifi is not activated.

This is the problem I try to solve. Enabling vowifi even if gsm is ok

What is your setting here

Exactly like your screen capture.
the call go through wifi when it’s enabled.

I never used VoWIFI so this might be off tropic but… I noticed on your screenshots that you seem to be using a VPN. Did you try disabling it and see if somehow it could responsible for inconsistency in the VoWIFI feature ?

yep, i tried :frowning:

I’m on a network from EIT, they use orange, SFR and Bouygues network.
i can choose the network
when on Orange, Vowifi work 1 time over 10.
when on SFR, Vowifi works each time i have no GSM. seems logic as SFR has validated the fairfphone, while orange did not.

the only problem is “how to force vowifi when GSM is ok and wifi is disconnected/reconnected”
it seems some settings say “don’t register using vowifi if there is GSM connection”

Yes I had a similar problem, but I put it down to using 2.4GHz I had to enable Flight Mode to disconnect the network to use W-Fi

But I now have the opposite of the screen shot by Yvmuell and all is fine.

If mobile network is unavailable then use Wi-Fi (which it is as I have Flight mode enabled)

My residence pretty void of Network. When I go to town I turn off Wi-Fi and Flight mode.

If I travel where there is Wi-Fi I enable it, but the setting above does not get changed. My pref is to check for network availability not Wi-Fi

My VoWifi runs quite stable, however I dont have more than 1 Wifi Network at home so not many Wifi disruptions. You say you can use different mobile networks. Do you choose manually? If not and its done automatically, maybe overall to many disruptions within a short time frame, so that its just too much for the FP3?

i have 3 AP from ubiquity + 1 cloudkey
all the AP are with the same SSID.
when the FP is in an area with poor wifi, it switch to a better AP, but it’s very VERY slow. the FP3 is a huge deception in term of wifi performances.

i tried to enable fast roaming in the ubiquity, it does not help.
i’ll try to put all AP on the exact same frequencies to see if it help switching faster, to avoid disconnection…

Is this tested with airplane mode active? I take it, even after 5min or so it is not reestablished although WiFi is working perfectly.

However independent confirmation on different carrier would be needed. Do you mind sharing your OS version?

I’ll try confirm this behavior this weekend and flag it with the FP3 A11 Beta if affected. There I can only test on my own Fritz hardware which are using their own mesh system to do device handover between AP. For A10 someone else needs to jump in.

What I can confirm already with carrier o2/telefonica subprovide:

  1. activate airplane mode
  2. enable wifi
  3. wait for vowifi (less than 10s on my end)
  4. disable wifi
  5. reenable wifi within 5s
  6. vowifi will not reconnect

5. reenable wifi after some deep breaths > 5s
6. wait for vowifi (less than 10s on my end)

I deduce there is some login protection interfering, probably at provider level. How a proper WiFi AP mesh setup behaves is however a totally different story.

This sounds like My FP3 doesn't like higher 5Ghz Wifi channels, especially channel 116 . Or are you saying the roaming between AP happens slowly?

Cannot reproduce running FPOS A10,VoWifi reconnects within 5 seconds

1 Like

This sounds like My FP3 doesn’t like higher 5Ghz Wifi channels, especially channel 116 . Or are you saying the roaming between AP happens slowly?

the roaming is slow. i expected it to be faster. sometime i need to be really out of range from an AP before the FP go to another AP.
but i’ll tweak a little the ubiquity, maybe it’s some error in my config.

What I can confirm already:

activate airplane mode
enable wifi
wait for vowifi (less than 10s on my end)
disable wifi
reenable wifi within 5s
vowifi will not reconnect

5. reenable wifi after some deep breaths > 5s
6. wait for vowifi (less than 10s on my end)

Let me do this exactly too
so . i’m in the basement, there is NO GSM.

  1. i put airplane to be in the exact same behavior as you.
  2. i enable wifi
  3. i wait… wait… waaaaaaait… no vowifi. i wait something like 5 minutes.

now, let do the same test, but with GSM coverage
so, i’m in my house, i have poor GSM coverage.

  1. i enable airplane
  2. i enable wifi
  3. Vowifi is active after 5 seconds ! good
  4. i go to my basement, FP changed the AP without disconnectedion: vowifi still works
  5. i walk in my house, FP changed 2 times from AP, and i did it very fast, but the FP did not disconnect from wifi: vowifi still works
  6. i now disable wifi.
  7. i wait 1 minute.
  8. enable wifi again: vowifi does not work

so the problem seems to be:

to get vowifi working you must have been connected to the GSM in the last few minutes!
if you try to enable wifi without having a GSM connection before, it will not work
so in my case, if i have a wifi disconnection, i MUST get a GSM connection before trying to have vowifi again.

edit: i forgot to tell you my version
in “about my phone” i have build “8901.3.A.0135.20211222”
is it A10 ?

yes :wink:

Can’t confirm that easily - did just activate wifi after 5min of radio silence and it still reestablishes vowifi

Doesn’t seem to be as reliable as claimed. Ran into the same problem after some rest.

Would you @yvmuell mind checking how your phone behaves if you

  1. enable wifi,
  2. wait 10s after vowifi establishes, then
  3. disable-quickly reenable wifi,

repeatedly like 3 -10 times?

Just to confirm, with either Flight mode or not, it can take around 23 secs to reconnect. This was a problem I thought I had solved, but now ???

I turned on airplane mode and then enabled and disabled Wifi quicky multiple times, without noticeable issues, VoWifi was always established within 5-10 sec once wifin connection is built. Same when I wait some minutes after setting airplane mode.

However, I did a third test with mobile data on and just toggle Wifi on/off and now I have Wifi call only on the SIM which I not use for mobile data.
Shorty setting into airplane mode fixed it.

The interesting thing I already noticed on my FP2 is, that the SIM which I use for mobile data, always has worth reception than the SIM I use only for telephony and both use the same network