Voice typing horribly inconsistent

Most of the time when I go to use voice typing, it will just say “start talking” and not actually receive any voice input. Fairphone 5.

Would you share a few more information about Operating System installed? Keyboard used, standard or any third party? Settings for voice input? Any special App you tried using that?

Have a look here

1 Like

I see in that post that I am supposed to remove all the updates for Gboard. How do I do this?

Should work under settings-apps-Gboard 3 dots upper right

I’ve done everything and voice typing is still inconsistent. I am pretty sure it is NOT a problem with Gboard specifically - I switched to FUTO Voice Input instead of Google’s own speech to text tools, and I am still experiencing the same problem. I cannot work out if there is any sort of pattern, except that every time FUTO malfunctions, Gboard does too and vice versa. (The separate voice recognition card that pops up when using the microphone button in Firefox and others also malfunctions occasionally, but nowhere near as often.) I tried various things with both apps - setting them to unrestricted, force stopping them and trying again, and messing with the microphone permissions of the various apps I was trying to use them within. Nothing I tried worked; whenever it started working again it was ALWAYS unexpected. It will generally work multiple times in a row but will stop shortly.

My hypothesis is that the phone’s firmware is not correctly wiring the microphone up to the app when it is supposed to, i.e. the audio the voice recognition actually receives is silent. I have no way of proving it, but would very much appreciate any debugging steps I could take to either verify or falsify this.

I have this problem, too, when using voice recognition within Gboard, it’s working very strange. E.g. when speaking a single word, Gboard doesn’t react, but when I repeat the word, it’s typed twice.

Voice recognition within Google search or other apps works well, though. Very strange.

Setting Gboard back and clearing the cache didn’t help. Maybe Android 14 will…