Virgin SIM data not working

I have 2 SIMs in my FP2, a Phone Co-op one and a Virgin Mobile one, both use the EE network. Usually I just use data on Phone Co-op (and Virgin is for free calls home) but having run out this month, I have tried to use data on my Virgin SIM, with no luck.

  • I know the SIM works OK in another phone as I lent it to my partner when she ran out of data on hers.

  • I have tried each SIM in each slot and that makes no difference.

  • Having set the settings to use the Virgin SIM for data, and with data ‘on’ for that SIM, I just get a “No data connection” message.

I stumbled across APN settings as a possible reason. So I tried to set up a new APN Name for the Virgin settings mentioned here:
I did this twice and each time it did not appear in the list of APNs.

Then, after ignoring my phone for a while, both of them were visible. However, now it is back to the old settings. However data now doesn’t work on either SIM. I’m sitting here in tears.

Under Settings > More > Mobile networks > Preferred network type, set the Co-op SIM to 2G and then the Virgin SIM to 3G/4G.
There is a strange bug that affects some phones/providers, but not others, where the 2G option will be missing. If you’re unlucky in that regard, this post may help.

Note that when you want to use data again on the Co-op SIM, you’ll need to the reverse (i.e. set the Virgin SIM to 2G, and then the Co-op to 3G/4G).

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.