English

Viewing the Forum badges gives a 500 Internal Server Error

Continuing the discussion from The forum: How are we doing?:

Ok, I could narrow that one down:

I assume that it has something to do with the number of badges (Marco has 13 and Saskia only 3) or with a specific badge.

Will investigate further…

Edit1: E.g. view @ben’s badges. He’s got 12 of them and no error appears. I’d rule out that the number of badges causes the error message. Maybe it is the “Fairphone First Edition” badge?
Edit2: Yep, seems to be it. @Sietse’s got only 7 badges, but he’s got the “Fairphone First Edition” badge and I can’t view his badges. Can you verify?

I can reproduce this error. And I can’t see my own badges. I always assumed it was possible to see everyone else’s badges, but not your own :slight_smile:

Hi all, waiting for a colleague to come back from holiday and then we are going to look into the forum, including this issue and the crashes we sometimes have.

So hope to report back in a week/1.5 week or so.

I love badges so I want them fixed :frowning:

Does anybody have cool idea for badges? :penguin: like I created FP owner badges but it’s a lot of work to apply them :<

Thank you, @Marco! I hope the issue with the mobile version of the Fairphone Forum will also be solved then.

let’s see, wasnt aware of that one good to let me know. I think the first course of action will be to update to the most recent stable version and see if that solves things ;0

if not well take it from there.

1 Like

Maybe not just that one but any manually granted badges? (only rick and marco have another one of those and they also have the first edition badge so it’s hard to figure out.)

But in my experience the problem comes and goes. I had the error some times when viewing my own badges and never had a manually granted badge. I think it may have to do with recent downtimes of the forum, because that’s when I always experience the problem.

Hmm, I have the badge issue continuously since granting the Fairphone first edition badge. It is luckily visible on my user card (which I was intending to have it sticky there), but I cannot access my badges page as well. Therefore I also believe it might have something to do with this particular badge (or with manual granting).

If there is a backlog in forum software updates, then I would like if this can be updated first to check the results from there. It was nice if the forum was accessible via Tapatalk as well…

1 Like

I confirm too the problems with badge viewing and it seems @Stefan pointed right the problem with the FP 1st edition badge (I can’t see the pages of users with that badge).
@paulakreuzer do you know of other manually granted badges?
And please…please…PLEASE try to fix the Firefox issue! Sometimes It’s unusable even with simple post reading, the scrolling blocks or jumps randomly in the page! And 90% of times I have to see the desktop verision of the page because the mobile one is blank :’(

1 Like

I believe it’s only the First Edition badge and the Customer Support badge.

1 Like

I moved 2 posts to an existing topic: Do you have cool ideas for forum badges?

1 Like

We have a new user with the Customer Support badge, @Reent. He doesn’t have the First Edition badge but I still can’t view his badges page. So that means any manually granted badge causes this problem.

I looked at Discourse Meta and found out that there is probably an easy fix: As far as I understood from this topic we just have to put the manual badges in a badge group. Like “Getting Started”, “Community”, “Posting” “Trust Level” & “Other”.

2 Likes

I had seen this server error myself, but did not pay too much attention to it. But now you’ve got me hooked on this badge thing…

[self introduction to all forum members still to come…@paulakreuzer: thanks for blowing my cover :laughing: ]

3 Likes

Sorry! :blush:
But I think you are still quite undercover. I only “outed” you to a topic with 65 views so far. :wink:

1 Like

We’re adding it to the fix list!

3 Likes

From the looks of it, you are running on a fairly old version of Discourse. Besides the possibility of UX glitches, there are security risks.