Video not working in Google TV

Yesterday I tried to play a Video from Google TV and on my FP4 it showed an error message, that the service was currently not available while on other devices it worked. Does any one have an idea how to fix this?

EDIT: Download of the Video is also not working

I know it doesn’t really help, but Google TV worked on my FP4 out of the box.
So I guess it must be something something about your configuration. Check if:

  • Your phone is properly logged in in your Google account?
  • Your phone’s WiFi connection is operational (can reach Internet)?
  • Nothing blocks Google (ad blocker, firewall, sensible setting, whatever)?

The phone has a proper Google account, paying the movie was working just fine. Also the Wifi connection is working fine.
The last point is not so easy to tell: I use Pihole with in my local network. Anyway with the same setup my Browser on my notebook can play the very same video as well as my old LG V30 running an AOSP based Android 11 OS and my tablet running Android 9. Also, I use NetGuard on both smartphone with the same setup. But even disabling NetGuard did not help.
And I can’t download the video on the FP4 while on all other 3 tested system that also works.

That could be the culprit. Do you have a Guest Network/DMZ bypassing any filtering?
If you can’t access/download the video it means the server Google uses (whichever it might be) is blocked somehow, by something. You need to find out by what.

To make things simple I would just try my phone on another, unfiltered network. Do you have any friends/family nearby? This would allow you to know if the issue is with your own network, or with the phone itself, and would make things much easier to pinpoint.

I switched off pihole and configured DHCP to use the router as DNS without filtering and that did not help. At the same time my other smartphone and my tablet both use the filtered DNS and they do work. So I strongly doubt that this is the cause.

Nah, it could had been that the phone isn’t recognized as a legit user of the network, and thus filtered. I don’t know, I obviously don’t know what you’re running on your Pi and how your Pihole is configured. All know is that your phone’s traffic gets filtered, and thus a filter is the most likely culprit.

Anyway, if you tried without any filters and it didn’t improve anything, you know it’s most likely the phone. You could try accessing those same links with a web browser (on the phone), so you get some more articulate error message than “Sorry, doesn’t work”. That might give you some additional clues.

And of course the eternal but always useful “Have you tried to switch it off and on again?”… :laughing:

Switching it off an on again was the first part, followed by cleaning the cache. Now I just tested reinstalling the app updates and trying with the previous version.
Nothing helped.
The network is fine as all other devices use the very same setup with pihole. And even without filtering it did not change, I will wait and hope to get some hints from Google after having talked to their support, now.

1 Like

Seems the sensible thing to do. I wish you luck! :slightly_smiling_face: