Very weird mobile data problem: I get my mail but can't browse the web

OK, I know it’s an odd behaviour but I often keep my mobile data connection turned off to prevent unwanted/uncontrolled traffic and also due to the impression that it saves battery, Now here’s what I have experienced the last two weeks or so:

  1. I turn on mobile data and start checking my e-mail (using the K-9 app). No problem, mail downloads OK.
  2. I then open my browser to check a website (any website), only to receive the message “webpage not available”. This is not app related, since the outcome is the same in three different browsers (Dolphin, Opera, FP default).
  3. After turning mobile data off and back on, sometimes more than once, browsing works again.

When on a wifi connection everything runs smoothly.

Has anyone encountered anything similar? It could be a provider issue just as well as related to FP software or hardware, but I find it extremely difficult to understand why data traffic works so that I can get my mail (from my job server and from gmail) but blocks me from the world wide web as it seems.


Did you use some VPN, proxy, or onion routing?

I only noticed a similar issue when I played aound with Orbot, turned WiFi off, and later on turned it back on again. Orbot then somehow got confused, and told me there was no connection even though there was WiFi - but somehow, the IMAP connection got through, while port 80 (aka surfing the web) stuff did not. Usually, turning WiFi off, shutting Orbot down, and turning WiFi on again does the trick. (Since I’m just trying out Orbot out of curiosity, this does not really matter.)

1 Like

I would also say it sound like a port problem.

Just the standard APN settings recommmended by the provider - which actually includes the proxy and port 8080. I tried changing the settinga to “not set” for both proxy and port but that didn’t make any difference: sometimes i get a connection but sometimes I don’t.

Of course it could be related to port 80 (not used by my email accounts). But internet traffic over a wifi connection uses the same port, right? And the problem only appears when on mobile data. Also, there’s no difference when trying to connect to a https site (presumably using port 443).

So it’s mysterious, and more so since it’s intermittent.

EDIT: have installed 'Net Swiss Tools" that checks for open ports, so next time conenction fails I’ll check whether ports are open or not.

I have the same problem :frowning: when i am not on wifi the internet hardly ever works! its really slow, only whatsapp is working, browsing impossible. a friend of mine says its because of the provider BOB that does not enable LTE… how can i turn it off if this is the problem? i also need help :frowning: thanks.

@tina25: No, I don’t think it’s the same problem, really. My mobile data connection is not particularly slow (around 3 Mbit/sec) and when connection has been successful it is also stable, And BTW, it doesn’t matter that your provider can’t offer LTE (4G), the Fairphone does not work on the LTE band anyway. Of course, compared to LTE, FPs connection can be felt to be slow (where I live, LTE connection is at least six times faster than WCDMA/3G).
Since your conenction is nmot completely dead I guess there¨s nothing wrong with your settings. It could be a case of bad coverage. If you try your SIM card in another phone on the same spot, is it better, worse or the same?

1 Like

UPDATE: I turned off the connection and then back on. My browser refused to open any website. ‘Net Swiss Tool’ reported that port 80 was open, and also successfully pinged a few IP numbers (e.g. google com).

So presumably this is not a port issue at all, but maybe caused by some kind of handshake error?

Do you mean a DNS issue? I did not understand what you mean with handshake error.

The DNS was what came to my mind, when you said you can ping IPs.

You mean that addressing IP numbers could work, but that something goes wrong in the process of ‘translating’ from a (name) address to IP number?

Don’t think this is the issue, since the ‘Net Swiss Tool’ app lets me write an address and ping it - I don’t have to enter an IP number. I can wirte ‘’ in the address field, and the app pings - so DNS seems to work.

‘Handshake’ is maybe a bad expression. What I meant was that maybe my mobile data provider for some reason can’t detect that port 80 is open. Either because my FP doesn’t send the right signal, or because of some malfunctioning at the provider’s end.

What happens if you try to navigate to an IP with your browser?

Did you try another SIM card?

1 Like

Brilliant idea, will try that next time it occurs (today it has behaved decently). This may have something to do with me trying out new APN settings (following the latest guide for Android phones from my provider Telia Sweden):
disabling the previously set proxy (choosing ‘not set’)
disabling the previously set port (choosing ‘not set’)
choosing PAP as authentication type (previously ‘not set’)
unticking ‘supl’ from ‘APN type’ (leaving only ‘default’).

Remains to be seen what will happen in the long run, but right now it works.


UPDATE: Although I’ve switched mobile data on/off a number of times since yesterday morning, everything now run flawlessly. So either editing APN settings did the trick, or else my provider did some system mmaintenance during the night between Sunday and Monday. I’m inclined to think that it’s the latter that explains it.
I hope everything works for my compatriot @Sverker_Finnstrom as well.

Glad it’s working for you now.

This topic is now closed. New replies are no longer allowed.