Very strange microphone bug

I’ve got a very strange issue with my main microphone (for calls):

  • 3 months ago, my main microphone was no more working at all: I contacted FF support and they sent me a new microphone module
  • For the last 3 months, everything was working perfectly

But since approximatively 2 weeks I’ve got again some problems but that’s a little bit different:

  1. If I’m charging my phone when I call, people can hear only strange noises
  2. Most of the time, the microphone is not working, but now a reboot sometimes solves the problem for a little bit of time
  3. At start, I was going to speaker mode to use secondary microphone but since 3 days, when I call, the screen is going black and I can’t do anything until the call end… If I fall on an answering machine, I must remove battery! (I tried to recalibrate sensor)
  4. I can’t use my headphones as mic (can’t hear anything), but it’s not a new problem.

My phone has been bought on FF official website as a reconditioned and I’ve got a rooted Fairphone OS v18.04.1.

It’s very problematic for me…
Any idea of what can be wrong?

EDIT: I’ve also tested with others application, it’s the same problem, not only for calls.
I’ve also tried to unmount module clean contacts and remount it with no luck…

Thank you

1 Like

Concerning your point 3., you can re-calibrate your proximity sensor:

Settings > Maintenance > Proximity Sensor

If that’s not enough or for other issues, please consult Fairphone’s Troubleshooting Tool.

1 Like

Thank you for your help but like I said in my post I’ve already tried to recalibrate it without sucess.
But it seems after a couple of reboots it’s now working (I hope it will last)

The only solution I found is to connect a Bluetooth headset.
I also tried a couple of wired headsets but it’s not working… (play/pause buttons too)

1 Like

Sorry, too quick reading on my part :blush:


First thing first: I got no solution in this post!

Hey Emerick,

I had the same issue one year ago; no chance to make the mic work at all; no calls, no voice messages etc. For some reason it just re-started to work after roughly two weeks.

A few months again I had the issue again, this time it didn’t recover, so I got a new Mic Module from FP, which fixed the issue instantly.

I can’t tell if the two issues were different ones, but the symptoms were exactly the same.

I’m running Fairphone Open OS (no gapps).

thanks for sharing your experience! Even if it’s not very reassuring…
I don’t know if I should ask a new module if it’s going to die in 2 weeks…
I’ll try to open my old module this week-end to test the mic with an oscilloscope or an amplifier to see if it’s really the component that is dead or if it’s the ADC/software.
I don’t know if it’s realy going to help to locate the problem but sometimes…

After disasembling the module, I can confirm that the ADC is not inside the module and the microphone part seems dead…
I will contact the support for a new module.
It would be nice for a durable phone to have a more reliable microphone…


Consider observing (and cleaning if necessary) the contacts on the back of the display module. This fixed the problem for me so far.

The grey pad on the back of the display where the microphone module makes contact (there are three such areas) should be shiny. Mine were dull, and somehow oxidized. I scratched them shiny again using the tip of a screwdriver, and now when I test (using Skype test call, for example), the recording no longer sounds muffled!

I also tried bending up the pins on the microphone module so they would push harder. Not sure if that also helped.

Hello Barry,
Thank you for your help, I just tried to clean theses contacts but unfortunately it’s not working…

I just noticed at the same time that my screen module is different on some points of the module sold on the FF Shop!

I don’t know if it can be making any difference but it’s maybe an old version/prototype?

There are different display modules …

Hi Emerick;

Sorry for the slow reply. Here is my update: if it’s any consolation, my phone didn’t actually work better for very long before reverting again to poor voice connection. So it is perhaps not such a great idea after alll.

I suppose the screen module has evolved over time. Maybe if you notify them and mention the problem they might be able to do a replacement?


Hi Barry,
I already contacted support and sent me a new module, still working at this time.
I unmounted my old module to search for clues and I suspect the problem to come from the power connector: mic wires on board are very close to the 5V input power ones (that can go up to 2A in fast charge!). As I’m regularly using an external power bank to face the tiny battery problem of the FP2, I think calling while charging can damage the mic component… (it’s maybe an active microphone as there is 4 pins?)
I now try to unplug everytime the cable before activating mic, let’s see how long it will last…


1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.