English

Using Sailfish OS on the FP2 - Experiences and Issues

sailfish
Tags: #<Tag:0x00007fefbd046e60>

#162

Excuse me, one quick question about formatting the microSD-card using an external computer:

I want to use ext4 instead of fat32, that also should work. In permission-configuration: Which user do I have to set as the owner? nemo? Right now, as I used the username of my PC, (fully correct) the Fairphone doesn’t have any permission to write on the SD-card…

Do I have to set nemo as the owner of the card, or at least, give him the permissions to write and read? :relaxed:

Thanks a lot for your help!


#163

Hi @mal, @explit and others.

Sorry about not reading and understanding the whole procedure before flashing to SFOS, but now I think I got it :grin: Live and learn, I’m getting the hang of this, actually :sunglasses:

So here’s what I did: I re-flashed my FP2 with FPOOS 16.11 using fastboot, booted to TWRP, removed the .stowaways folder just to be extra sure, installed SFOS 2.0.5.6 again from zip file, filled in the details, skipped the tutorial, and…still no video recording for me :dizzy_face:

Now I’m really confused. Going to try it with FPOOS 16.12 in the meantime…


#164

Video Recording is broken atm. Mal- is informed, i hope he will fix it soon.


#165

Oh d’oh, good to know. I can now stop my headbanging…for a while :disappointed_relieved:

Thanks for digging into this! Give me a shout should you need help with testing or swatting bugs!


#166

I have no idea why video recording supposedly doesn’t work for some people. It works without problems on my device. If it indeed doesn’t work then output of dmesg, journalctl -a and /usr/libexec/droid-hybris/system/bin/logcat is needed, Those logs should be taken after a reboot and then as soon as possible try to record a video and then get the logs.


#167

And you didn’t do anything else after installing the Sailfish OS zip like trying to update or something? You shouldn’t do anything else after installing the zip.


#168

Thanks, Mal- i will send you some logs!


#169

Hello lovely community,

i just gave Ubuntu Touch and FPOS a chance, but in my opinion SailfishOS is the best operating system for the FP2, especially regarding stability and efficiency. Thank you very much, dear porters.

Unfortunetaly video recording doesnt work on my FP2 too. I uploaded the logs you asked for, @mal ( https://file.io/Ay6gdr )

If you’ll run short of time with porting, i could probably help you. Just contact me in this case.

best regards


#170

That link to the logs doesn’t seem to be working. Is your installation just the normal installation without any modifications or packages not coming from Jolla Store or Warehouse?


#171

Ok sorry, then try dareit.de/video_capt_logs.tar.gz , this has to work.

I tried after fresh installation and again with a few packages installed from repositories by openrepos.


#172

Are you sure you have the correct system.img (from 16.11 fairphone open source os manual installation zip) flashed on the device? Please try to fastboot flash that again. At least one other user with camera issues got it working again after reflashing the android base (although he flashed system.img from 16.12). You can try both and report if anything changes.


#173

I tried both system.img again, but without any effects on the video recording.


#174

hi mal!

can we update to 2.1.0.9 or is there still much work to do?

cheers and many thanks for bringing sfos to fp2!


#175

I would like to try going back to 16.11 and try that, but I can’t find the download link anymore. Are there not links to older releases anymore?

Reflashing system.img of 16.12 didn’t help…

And here are my logs, finally: https://file.io/CILVoz

EDIT: I found the link, downloading 16.11 now.


#176

I just updated my FP2 from 2.0.5.6 to 2.1.0.9. Phone booted without issues, and everything seems to work fine. But I guess we can draw more accurate conclusions after a week or so.


#177

good to hear. are you using 16.11 or 16.12 as basis?


#178

I don’t really remember. The first SFOS update was done a long ago. Is there a command line method to check?


#179

Download Aida64! In the ‘Sailfish’ section you can find your Android base.


#180

Thanks, I had forgotten about AIDA64. Already had that installed.


#181

OK, it’s an antiquity :wink:
I thought >=16.11 was necessary, but obviously I am wrong. I can easily differentiate between 16.11 and 16.12 with SFOS 2.0.5.6: if I use 16.11, everything works, if I use 16.12, my FP2 reboots every 30 minutes. so I thought that you could tell me which would be the better base for 2.1.0.9, but obviously you have a very different configuration than me. thanks for finding out !