Using LineageOS on the FP2

It’s weird because some people have problems with a SIM in slot 2 and some don’t with Lineage. But the phone of @chrmhoffmann does the same thing so hopefully he’ll be able to fix it.

Wow this is really great! Thanks!!

It’s working great for me, and for the biggest part more user friendly than fp open os which I was using until I flashed last week. I don’t understand programming very well so I’ll give feedback in my lay language and hope it’s helpful :wink:

The only bug that is bothering me, is when i’m calling (via normal phone app as well as whatsapp); the screen goes black until the other party disconnects. During the call there is nothing I can do to disconnect, which can be pretty nasty if you don’t want to leave a 2 mins long voicemail on someones box ;). I think this probably has to do something with the proximity sensor? Is there something I can change in the settings so that I can turn on the screen during calls, for instance with the on-off button?

Overall, this port is a great work! My LAN integration isn’t very fine, because of
the wrong MAC. But for now I can deal with it.

Did you get UnifiedNLP (nogapps) to work? The self check shows no binding with the

I hope the FP devs will get the proximity calibration tool into F-droid.

Hi, I don’t know if this works with Lineage, but there is the setting:
Go to Settings --> Accessibility and activate “Power button ends calls”.

Actually the screen should not get dark as long as your ear stays away from the phone during a phone call.

@rkennke , do you have the modem files 4436.1.FP2-0-01 (from Fairphone OS 17.05.2) installed?

A post was merged into an existing topic: Porting LineageOS to FP2

UnifiedNLP (nogapps) works like a charm here…

I installed it following the installation instructions that can be found on github:

  1. Download NetworkLocation.apk

  2. Mount /system read-write: from your PC, call
    adb root && adb remount

  3. Copy NetworkLocation.apk to /system/priv-app: from your PC, call
    adb push NetworkLocation.apk /system/priv-app/NetworkLocation.apk

  4. Reboot: from your PC, call
    adb reboot


So you must do it over adb? Copying with Amaze with root permissions does not do the same, even when it shows the apk in place? But direct support like CM had would be better. It would survive an OTA update. Otherwise you have to do this procedure every time.

I’m not quite sure why it does not seem to work if you simply copy the apk to /system/priv-apps/ with Amaze with root permissions… I never tried that. But @oli.sax had a similar problem with the microG Services Core apk.

Yes that could be that the “adb way” is required… I’ll try out and let you know :slight_smile:

On the github page they mention also a patch, but I didn’t understand if this patch is for the APK (when building it?) or for the OS (to fix permission?)

Admittedly, the instructions are a bit confusing. But if I understand them correctly, the patch is not needed when installing to /system/priv-apps/ via adb :slight_smile:

Thanks for the tip! Practical workaround :slight_smile:

@Gerry it turns black immediately when it starts dialing, so before the phone hits my face.

UnifiedNLP works with the adb method.


This issue could be fixed in Fairphone OS 17.05.2. A hint from the respective release notes:

Fixed the proximity sensor calibration data not taken into account


Hopefully the latest modem files have this patch included. Which modem files do you use currently?

I believe the Fairphone community which works on a Lineage OS port for Fairphone 2 should team up with the Fairphone OS developers to get such patches first-hand.

17.05.02 is not release in terms of sources i think.


This requires Fairphone’s proximity sensor tool to be installed which obviously is not included in LineageOS

1 Like

Hello, i am no longer a user of Fairphone but i also use LineageOS. I wrote an article in german for a fully opensource-Android with Lineage. Maybe its helpful for those who switch from Fairphone Open…


Just installed LinageOS on the new FP2 of my wife, before I handed it over to her.
Update worked great, but the welcome message App crashed if there is no SIM Card available. After installing a SIM it worked quite well.

I noticed one thing with the current build (20170615): When connecting to a WiFi during first start up, the assistant app crashes. The only way to finish the setup assistant was not to use WiFi. Later there was no problem to connect to the WiFi.
I came from a GAPPS free Fairphone Open OS and used the howto mentioned in the first post to change to Lineage.

I want to use microG instead of GAPPS, how can I install Xposed or is there any other option to get signature spoofing to work?

There is no working xposed version available for android 7 / nougat.