Using LineageOS on the FP2

Were you asked to re-enter your PINs or have you stored them permanently? Maybe the problem lies with querying/forwarding of PINs to the modem firmware…

I thought the problem is there and removed PINs for both SIMs - didn’t change anything.

So you were asked for your PINs, re-entered them, and the phone did not connect? Strange…

Does that happen after wakeup from standby?

I was asked for the PINs and it didn’t seem to work. So I removed the PINs of both cards with an other device, but both SIM icons still showed “no signal”.

I don’t think this has anything to do with standby. As someone said above, I also don’t think that this Samsung-Story has anything to do with this problem.
It’s about reconnecting after leaving the flight mode.

1 Like

Thanks for clarifying. :slight_smile:

Looks like the modem firmware needs an appropriate update for Lineage OS to fix that issue…

Installed @chrmhoffmann’s build yesterday via @z3ntu’s current TWRP over my FP Open OS 17.04.0. Had to do factory reset though (flashing the .zip would give me Error 7, after reset, it installed without any problems). I am really impressed, how well everything works already! Huge thanks to @chrmhoffmann :gift: :heart_eyes:

Besides the small (already mentioned) inconveniences there is one issue I have not figured out yet: I have not encountered any issues yet.

I stored all media (photo, music…) on my external SD card. The card is recognized and mounted in LineageOS however without write access (Gallery can see the photos, OpenCamera cannot store them. In Lollipop I modified the platform.xml (or used the Xposed module) to grant access to the SD card.

How can I give write access to the SD card in Nougat? Since I also cannot see the /system partition in Amaze…
EDIT: I was just too dumb to make Amaze a Root Filemanager, then I could edit the /etc/permission/platform.xls and now I can store photos and listen to music.

…and something on the long run:
How will we be able to update this OS? The standard approach in the About Phone section does not seem to work…
However there is not a big hurry since the Patch level seems to be May, 5th :+1:

Let’s hope the Fairphone devs will also jump onto the LineageOS train, now that the community served it to them on a sliver platter :clap:

1 Like

You can periodically check the top post of “Porting LineageOS to FP2” for newer versions.
As long as this is an unofficial port, there will be no OTA updates available.

Once the code is cleaned up and everything is working well, the port may be upstreamed to LineageOS, thus becoming an official port with OTA updates from LineageOS directly.


Sorry forbeing unprecise, I only use one SIM-card. By re-unlocking my SIM-card I meant that I was asked to enter my PIN again after I switched back from flight mode.
Have you tried to flash the recent modem files as mentioned by @explit? You could also try to temporarily disable the second SIM-card before reactivating from flight mode. @Johannes mentioned in the other thread that also some people using the regular FPOS experience some bugs with this.


Maybe I was imprecise, too. I have no PIN on my SIM-Cards (using two).
But how does one disable a SIM-Card? I can’t find a menu entry.

I had the issue with the new and the old modem files. But re-flashing “dirty” without wiping anything has brought the SIMs back to life and I could keep my apps and data.

I don’t know wether this helps, but I’ve an MI3 with LineageOS, too. On this device one have to re-unlock the SIM-card after switching back from flight mode, too. So this might be somewhat normal for LineageOS.

I don’t think it is a “normal” lineage behaviour.

When my Fairphone2 was in repair for a week I used a Wileyfox Swift with Lineage 7.1.2 (iirc) and it didn’t show this behaviour (and I used Flightmode a lot!).

Lack of SIM service after switching off airplane mode could be a regression in Lineage OS. A respective bug has been filed:

1 Like

Finally managed the move from android 6 to lineage. Procedure works as described (installed TWRP first than lineage). No problems. Same symptom with flight mode here: pin has to be entered after disabling. Great work!


Looks like the file was deleted. I get a 404 error when following the link ( ):
Does anybody know what’s happening?

The developer released a new build;

1 Like

I have trouble with adaway app:
Get the error message:

The folder does not exist. If I try to create it manually (with total commander) it just not creates it.
Anybody with the same problem here?
I have root access, of course.

" ! Copying failed

Copying of the Hosts file failed!

Please read Help for more information.

Help Close"

Have you tried using different versions of “Ad-Away”?

Hey everyone,
during calls my display is switched off so I use the work around to end the call with my home button. Now I tried to call a service hotline where I should press numbers to choose a menu.
Did I miss some settings or does it relay to the proximty sensor which maybe is not supported yet?
Thank you
I’m on the latest version 0602

But what about Widevine on FP2 Lineage OS? Because if it isn’t possible Fairphone users couldn’t install Netflix for example…