English

Using adb backup on FP1

I’ve been trying to backup an FP1 with adb. The backup finishes in a few seconds without any error but creates a file only a few bytes. The same thing is described at Adb backup, starts but doesn’t save anything

I tried with some older releases of adb from the fedora build system ( https://koji.fedoraproject.org/koji/packageinfo?packageID=12895 ). The last good one is android-tools-20141219git8393e50-5.fc24.x86_64.rpm . It ran fine on Fedora 28, so I’d guess it would work on other RPM based linux distros.

To install:

wget https://kojipkgs.fedoraproject.org//packages/android-tools/20141219git8393e50/5.fc24/x86_64/android-tools-20141219git8393e50-5.fc24.x86_64.rpm
sudo dnf install android-tools-20141219git8393e50-5.fc24.x86_64.rpm
2 Likes

I moved this to #software:fp1-android-4-2 because it is a general topic and not an indvidual help request.

Hello, that seems interesting but I don’t understand really what I could do exactly with that :speak_no_evil: Could it help me per chance to use again my FF1 with its new Battery from Internet (this no name battery from Internet, which could save the phone but unfortunately still doesn’t make it totally trustfully because of sudden crashes) ? :sunglasses:

A backup, factory reset and then restore might do it some good.

Ok, thank you Sam, I’ll have a look at this app abd backup and then maybe I can finally re-use my FF1. But isn’t it too dangerous anyway because of the very old android version? (I don’t want the FF2, too big format for me, and obviously also a lot of problems).

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.