USB to PC-Connection: no access to build-in storage but access to SD-Card and a lot of apps can't be started after(!) disconnecting until rebooting the phone

…which actually suggests that it hasn’t installed correctly. What message do you get if you start the “Fairphone Updater” app? It should say “You are running Fairphone Cherry 1.6 - there are no updates available”. If it says something else, the update apparently has failed. If it does say 1.6, clear the cache and data of the Fairphone Updater app and reboot your phone - this might put an end to the warnings.

As to why you cannot connect to your PC, I’m sorry to say that I have no idea.

Maybe @Anna_ needs to download and install the Mediatek usb driver. I don’t know right now where I downloaded mine though.

Does someone know a reliable source where to download the drivers?

Thank you all for your help! For the moment I couldn’t find in the Play store this Mediatek usb driver -I guess it’s an app?? Nor in google.
But yes, the problem finally is that I can’t update to 1.6.

It’s not an APP, it’s a driver for your computer, so it recognices the FP.

Hi @Stefan, thank you for the advice.
I installed the driver but it doesn’t work by the moment (this one: . On the other hand, I reset the phone and somehow I could update to 1.6 cherry… that’s something isn’t it?
I look for some ideas regarding usb connection anyway!

Problem is, that this is not the driver for our phone. Our phone has a chip set with the number MT6589, so you need a driver for e.g. MT65XX. Unfortunately I could not find it on their website (I had visited the one you posted).

Maybe you, @madde , know where to download the appropriate driver (Since you suggest in your CM11 post to download the driver. I remember that I tried XDA for the driver, but the link was broken.).

Have you tried this link?

It says, “you must be logged in to do that”… I don’t want to register only to download a driver. Is this really necessary?
I have installed a working driver on my PC and I don’t remember registering for it.

There was another link in the fairphone FAQ somewhere…

1 Like

this was helpful, lidwien, didn’t see the MTP option before. i got the same problem as Roland768 described after upgrading to cherry. with MTP everything is fine again. thx

Hi there, trying to find out all the solutions, but I am feeling blind here. I have the same problem with my 2nd batch FP1 (cherry 1.6): no notification when the USB is plugged in my pc, the option USB internet on my phone is grey / can not be tabbed and I don’t understand the MTP thing. Can anyone help me here? Is the solution to install a driver? Normally my PC will connect me automatically with neccessary drivers or driver options; now, my PC only says ‘no access to device’.

@Mariette: So your PC does detect the FP?

Did you try it with another cable?

@Stefan, it doesn’t detect my FP. I guess I only have one such cable fitting in the FP, but I’ll search for another one.

1 Like

Please find a second cable (maybe borrow it from someone else) and post back if it still doesn’t work. :slight_smile:

Hi all! I don’t know why, the problem with the USB connection was solved. I had tried different cables, but it didn’t work… Until today, I tried another cable + took off the phone case. -_-'
well thank you all for the posts!

1 Like

Hello :smile:

getting back to the original problem…
I installed the update to slve the storage problem yesterday and under the other 1.6 update before I was able to access both internal and SD card memory via the “USB mass storage” option. Since the update I can only access the SD card.
I was able to transfer photos via the media option, but nonetheless I think it should be possible to access the internal sotarge with the comuter as well.
Does anyone have an idea how that could be achieved?
kind regards,

Hi Christian,
as you say, after upgrading to 1.6 or later versions, the “USB mass storage” option gives you access to the external SD card only.
Choose the MTP alternative instead, and the phone (including all open/accessible folders in your internal storage) should be visible in your PC’s file explorer - at least if you’re running Windows.
Linux systems might be a bit trickier depending on your distro, but there are different solutions that works.
If you’re connecting to a Mac, I’m sure that there are ways of doing this, too, but I have no ideas about them, being completely ignorant of Apple technology.

Thanks kgha,

so thereis no way of accessing the phone storage at all…
Any idea this might be possible with a later update?
Or any ways to hack into the storage?

I just lost all notes and app settings, inculding whatsapp message. I had backed up whatsapp via the option in the menu and whatsapp only confirmed that the backup was saved in the internal storage. I thought that woul have been backed up with the backup&restore app… but no.
I guess I could use the file manager to try and find the file and move it to SD from where I can access it…
but just out of principle I’d think there should be another way to easily access all types of files with a computer… and in my opinion that would be the usb mass storage option…
but then I’m mostly ignorant of android ad its features… just got my phone recently

Excuse the silly uninformed (but serious) question, but isn’t whatsapp keeping your conversation on its servers? Think I heard as much a whole ago…

Don’t know what you mean by “phone storage”? System folders are not available, but all folders that you normally can access as user (downloads, photos, music &c) should be accessible if you connect with a USB cable and choose the MTP option.

If whatsapp stores its backup file in the internal storage (which IMHO isn’t the best option), and you after backing up whatsapp has performed the unified storage upgrade, I’m afraid that file is lost and gone forever.

1 Like