USB to PC-Connection: no access to build-in storage but access to SD-Card and a lot of apps can't be started after(!) disconnecting until rebooting the phone

This happens since some weeks, unfortunately I don’t know the exact date because I don’t use the USB-Connection very often.
Before that, it was no problem: connecting via USB, two drives appeared in Windows (7 32-bit) tray, activate USB-Access in wipe-down-menu and I got full access to both memory-areas, build in and SD-card.
Now, both drives are still there but only SD-card accessable, clicking on the build-in I get the message: insert medium (or so, it’s in German).
And worse: After disconnecting the phone a lot of apps seem not to be installed any more. There are Icons on the screen, but tapping them brings the message “not installed”.
After a reboot, everything is allright (until the next USB-Connect). But it is very annoying to reboot the phone and also not to have access to the internal memory. Yes, I can copy all I want to the SD-Card before connecting, but this is no solution.
By the way, MyPhoneExplorer is still able to connect (yes, I used it also before the issue).
I found some similar topics in the support area, but no one with a solution. I do not have any of the software mentioned there.
So, what can I do?


I think this has something to do with the unified storage update. Do you connect your phone in MTP mode?

No, I’m using USB-Memory (“USB-Speicher”) first bullet point, before and after the issue.

As I understand it, after upgrading to Cherry 1.6 the USB-Memory option will only allow access to the external SD card. You should use the MTP option instead. If you connect to a Windows system your phone should turn up in the file manager (windows explorer). Not sure how it works on a Mac, and if you’re on Linux you might have to fiddle a bit to get it working (depending on your distro).

1 Like

I supposed, that it could have something to do with the system update, but wasn’t sure. Was this behavior published anywhere?
I switched to MTP, Windows recognized a device “FP1” and in fact, all seems to be accessable.
After connecting by USB all is visible, no further permission is necessary.
After disconnecting, all apps are still working.

So, the problem is solved, many thanks!


1 Like

Lucky you. On macs we are obliged to accept the extraordinary intrusive google app… The only way I managed to avoid that has been to install the (very good) Samba filesharing for android app (by “Funkyfresh”, others work clearly less well).
The app works over wifi rather than USB, which will certainly be slower for large transfers, but indeed for batches of photos or mp3s for instance it’s almost instant…

It doesn’t. The same behaviour has been reported by multiple people (me, among others) on the old forums. Searching… Ah, here it is :smile:

No solutions found, but a hard reboot (powering completely off and turning the phone back on) works. Connecting in MTP mode instead of USB storage mode might also work.

So here I am again :frowning:

It works, in principle. But today strange things happend: I exported a GPS-Route from Google MyTracks as csv and kml. Then I wanted to transfer it to the PC, but: the file can’t be seen in the windows explorer. There are three older files (csv), I see them and I can copy them. But the newest file is not there, although I can see it in the Android filemanager on the phone, together with the three older, so no wrong folder or so.
Then I copied the file to a folder of the SD-Card, looked with Windows explorer there, and: there it is!
But still not to be seen with Windows File manager in the Folder of the phone.
What does this mean???


When you connect your phone to the PC you probably have to use the Media device (MTP) option.

Using the MTP-option solved the first problem I described in the initial post, I still use this mode. So I thought, it worked now, but not really.

I guess that MTP possibly does not recognize klm files…? This is a strange behaviour though…

It has nothing to do with kml. I saw three csv-files in windows explorer, bur four csv-files in FP filemanager. I saw five gpx-files in windows explorer, but six gpx-files in FP filemanager and so on.
Today, the story goes on: I told, that I copied the files from phone to SD-card, where I can see them also in Windows. Now I took such a file with the mouse and drag it into the phone directory. I expexted, that this would give a message, that the file is already there, or that there would be two files. But the third happend: there was no message, but from then on, I could see the file also in the phone directory in Windows explorer.
I had long experience with computers and saw a lot of strange things, but normally I had a clue, what happened. But this behavior is weird…

1 Like

Hi all,
Sorry I’m in the minus 10 level but… Where in the phone can I find this MTP option? I’m trying to connect it via USB to my PC but it’s not working…
I guess I should see a USB option in my notifications panel, but I don’t (I guess that notifications panel is the black screen appearing when you wipe down the home screen, isn’t it?)
Thank you in advance!

When you have plugged your phone to your pc, you will get a notification that your phone charging through the usb. Tab on that notification, and then you will see the option to connect by MTP.

I have the same question as Anna, how do i turn on MTP, where is the usb menu and what is the notifications panel?
not all of us are used to smart phones. flying blind here.

Don’t worry, just tell me to explain it more in detail.

Plug your usb-cable in the pc.
Plug your usb-cable in the phone. Immediately you will see a line on top of the phone “USB Charge only” and this message disappears again.
Now swipe the phone from top to bottom and the message “USB Charge only” will appear again.
Tab on “USB Charge only”.
In the next screen option four “Charge only” has a blue dot on the right.
Tap on the second option "Media device (MTP)

Hopefully this helps you more.

I agree, but you have your phone in the “only charge”-mode, so this message appear.
If the phone is already in MTP-Mode, the line will be “connected as media device” or so (sorry, my message is in german). And If its in USB-Memory mode, the message will say that. Unfortunately I don’t know any other way to get this menu than to wipe from the upper rim of the display down, when the phone is connected with a PC by USB, although you see the “settings”-symbol in the left upper corner when you got this menu, and you can go back to the settings from that.


Thank you Lidwien for your answer. The problem is, I don’t have this notification. When I plug the phone to the pc, it just shows the battery is charging. I tried this with 2 pc’s, so I discard any problem with the pc.

And swiping from top to bottom after connecting the cable doesn’t give another screen?

When doing so I just see the notifications panel… By the way I see a Fairphone update warning I’m using 1.5 version and I should update to Cherry 1.6. I’ve been trying to update to 1.6 for several times but there must be something wrong with it… The phone apparently downloads, installs and restarts correctly but then I receive the same warning again :S