USB port stopped working

Hi, the USB port stopped working on my FP4. It began with earbuds cutting on an off, and now the charger cable doesn’t work at all. I tried moving the cable in case of a bad contact but nothing happens.
Any advice?

Use a thoothpick to carefully clean the USB port.

1 Like

I tried, it doesn’t work.

Perhaps there is an Angel living nearby. To get your USB port tested if the Angel has a USB port for a Fairphone 4.

The more nearby is too far from me, but I’ll try and contact him anyway. Thank you.

It really sounds like a dirt issue. I get this regularly from dust it collects in my pocket. Plugging the phone in then compresses the dust until there is enough to block the connection.

I don’t think a toothpick does the trick as it might be too thick. I usually use a sewing needle and really scrape dust flakes off the bottom. Obviously you have to exercise caution, but I don’t think you can easily damage anything.

1 Like

I did it and still the same. :pensive:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.