USB-OTG Storage not working

since update 1.6.2 my fairphone2 is at least able to find und read the content of an usb-stick connected with an usb-otg cable. But i can not perform any write operations.
Amaze shows the rights for the usb-otg with “rwx” but simly does not performe any write operations (also no error messages).
Switching USB between mtp or sd-mount ( with connected PC) , no resault
Testet with different file manager, same result.
Cable and usb-stick working fine with Samsung note or s6.
Has anyone experienced the same problem or an idea how to solve it?

Best regards

Let’s rather be happy that you can at least read files from USB OTG! This also didn’t really work on the FP2

I’m still on the very first version of Fairphone OS (my FP2 is like it arrived to me im january), because of the bug in the first OS update, that made USB-OTG connections very complicated, and on my phone it works like a cham.

I’ve had really nice personal contact with people of the Fairphone team and of the community during the last days, and we talked about this problem and were convinced, that it really and finally was solved with this update.

But after reading your posts, it seems to me that maybe there are still problems.

So it would be good to know if everybody is affected or if the problem only occurs to very specific configurations.

1 Like

Could be the same permissions issue/security feature as for SD cards.

Try one of the solutions from the 2nd or 3rd post (depending on your skills) from this thread:

I get the same behaviour with 1.6.2RC: reading works fine, writing does not.

Creating new files/directories:
When trying to create a new file/directory with Amaze, the request for root permissions is shown (my FP2 is rooted). If I deny, the file/directory is not created. (If I grant root permissions, it works - but this is not a valid solution for most).
If I try the same on the additional SD card in the phone, I can deny the root access request, because Amaze raises the Android selection dialogue to choose the storage-device that I want to use (internal, SD card, usbotg). With the SD card being selected, I can create new files on the SD card afterwards.
However, this Android selection dialogue is not shown when trying to create files on usbotg, thus without root I do not have write access to the USBOTG-filesystem.

Modifying content:
When trying to edit e.g. a text file (rw access rights) with Amaze File Editor, this fails on both USBOTG and on the SD card - there’s just an “error” toast message (instead of “Done”). Modifying files with Amaze File Editor only works on the internal storage for me.


Editing platform.xml (with root) as described in the article linked to by @paulakreuzer works for me: I can create and edit files on both the SD card and USBOTG now.
However, AFAIK this needs root access in the first place.

I am missing the device selection dialogue for USBOTG, this would at least enable us to copy/move/delete on USBOTG as well.

BTW, on editing files (typo fixed): should it actually be possible with the same mechanism (device selection) to be able to EDIT files from various apps (such as Amaze File Editor) on external storage, even without root?

Thanks for the replies, but since my phone is not rooted, I could not test the mentioned solution.
However i can write (rename, create, delete) on the internal and external SD, but not on the otg-usb.
(Amaze still shows “rwx” permission for the otg-usb folder)

Best regards

Just figured out that total comander let me write on the USB otg. (Amaze still not)…

My FP2 is on FPOS 1.12.0, USB-OTG was working some days ago while I was using Fairphone Open OS since I am back on the normal OS without Root USB-OTG is no more working. I can´t even read through USB-OTG. Any ideas? My FP2 is of course encrypted.

I am using my Fairphone for one year now but it is still full of bugs, I still have 1-3 reboots a day. I am not very happy with my device. Hope Android 6.0 will solve some of the issues.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.