USB OTG (on-the-go) on Fairphone 2

Hi Fairphoners!

I am having trouble connecting my Garmin eTrex 20 (handheld GPS device) via USB on-the-go to my Fairphone 2. I tried this once some time ago with the preinstalled Fairphone OS and just remember that I could mount and access at least the microSD-card in the device - which would be sufficient for me at the moment. (When connecting to my (Linux) computer, two drives, internal storage and microSD card, are mounted).

Now, I am running the self-compiled (1st) version of the Open OS (with the unified NLP modifications, rooted and TWRP recovery installed, as explained here in the forum). When I connect the cable, the Garmin switches into mass storage mode but nothing happens on the Fairphone side: No notification, no files in “usbotg”, nothing. I also tried installing the “Mountie” app, but also the mountie-directory remains empty. I connected the Fairphone to the computer and disabled MTP mode, but it did not help. I experience the same behaviour when connecting my MP3 player (Sansa Clip+).

Does anyone here have any suggestions how to fix the problem or where to start searching? Is there any hope that installing the new released version of the FPOOS will fix the problem?

Thanks a lot in advance!

1 Like

I am still waiting for myself to replace FPOS to FPOOS, so, I am rather thankfull to your experiences anyway.

What about mounting manually e.g. by (terminal Linux, e.g. temux)
root# mount /dev/block/sda1 to /mnt/media_rw/sdcard1 ?

Thanks a lot for this hint! I tried to figure out how this works exactly but I am kind of new to this stuff and could not find any documentation on the “mount” command. Can you give me some further advice?

I did find out that inside /dev/block three new files appear when I plug in the cable: sda, sdb, sdb1

It seems, however, I am not using the correct syntax for the mount command, it always returns:
Usage: mount [-r] [-w] [-o options] [-t type] device directory

Btw. Will mounting to /mnt/media_rw/sdcard1 not cause trouble with the sdcard inside the phone? Can I also use /mnt/media_rw/usbotg or create a new directory?

sorry for answering late but the whether was too nice :slight_smile:
surprise to me this evening: I had the same problem as you did :frowning:
fortunately I found a quick link ( with the answer:
just prepend busybox to every linux/droid shell command e.g. busybox mount …
Of course having installed busybox which is mandatory for all this root-shell stuff.
Also I hope you have equivalent good finger support given by a good terminal app (temux to me) and …
… a blutooth hardware keyboard for this tedious finger work.
adb shell or cabled keyboad cannot be used due to the otg usb occupation of the sd stick.

Thanks for the help! With busybox I managed to mount /dev/block/sda or /dev/block/sdb1
to /mnt/media_rw/usbotg. (command: busybox mount /dev/block/sda /mnt/media_rw/usbotg)

I can now access the mass storage using the root mode in Amaze in /mnt/media_rw/usbotg. But still, nothing appears in /storage/usbotg. Trying
ls /storage/usbotg
opendir failed, Permission denied

I found out that usbotg is owned by system:
drwxrwx--x root sdcard_r 1970-01-01 01:00 sdcard1 drwxrwx--x system system 1970-01-17 23:48 usbotg

Might that be the reason? Any additional ideas?

For this problem, I found out how to use adb shell over wifi:


Second: do not mount a whole stick: sda, do mount a partition: sda1.

Edit 2020-08-07 by @TobiasF: Replaced link with quote because the original post was archived and not publicly accessible anymore

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.